summaryrefslogtreecommitdiff
path: root/dev-util/debugedit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-util/debugedit
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-util/debugedit')
-rw-r--r--dev-util/debugedit/Manifest2
-rw-r--r--dev-util/debugedit/debugedit-4.16.1.2.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-util/debugedit/Manifest b/dev-util/debugedit/Manifest
index 239ac099ab04..02fe10d0ea0b 100644
--- a/dev-util/debugedit/Manifest
+++ b/dev-util/debugedit/Manifest
@@ -1,5 +1,7 @@
DIST rpm-4.16.0.tar.bz2 4341683 BLAKE2B 5161e5dcc6d9a1f1d4b8e44740fb368050b808fd9e8b8276fb17b530a4642e1b9ad104b5a30c0071215aef7f823eeab10988dd41f73af1c52d575529c374b5eb SHA512 177119c3ac3d48980db55bb4ba0fdbb2a911968e5efc690bfa8cc343f850fc90531cc0dee6dd8e45d2b14f0d951ced35bd8893d24011b7f270745d281ddf4e3d
+DIST rpm-4.16.1.2.tar.bz2 4346745 BLAKE2B 17485b1e73b30586acb8e9be53bfb0bd430fa05e826755729c68367c798e8cad039f091731b6effbe9fa9b7d6c4018abd6feec94f032230cbbd6068e9080573a SHA512 066b67838312f9ad076285fe8f43527aded694f5562ead4e90df48675f2e99c1f2d68693fd20b2037e2614b978ed94c417753e2dbd055a9869b45264cd932afc
DIST rpm-4.16.1.tar.bz2 4348973 BLAKE2B 5f415099ed5b4f3425c1cbd02476c3066ef51e8efbe09829c0c7d9732cfdeed76ab0c5eed113a1b007d35bf5d5fb1c60543b7ef23319ba0f63550d598e98dcdd SHA512 cbce8381e7a0bdaf2c7529d0ac91fda15e663db7a76b02652d53327ebcd7d5b6b6154d5e88feeda87f71727a036e7a2afcd57c7dcddef610e32957b9e430d367
EBUILD debugedit-4.16.0.ebuild 1765 BLAKE2B 463b1295cb2cf4d8fd4914546610844495065a62d164b099b3352761b2329cb016d9fa15a1cfab3d8f348a1d9c9392eb4debac627b58af9402cc01d99244eba1 SHA512 29e6a33ff92e86ba3c7eb52eb593c97af3ca52fdf9df999984cdbe7ea2c2a3039619738b0877af42ff1b77515fac2249d603827abbe7c9bba86368f959242a29
+EBUILD debugedit-4.16.1.2.ebuild 1770 BLAKE2B 9657d25e12679c563a0dd2f6220a58844c043f28ead997e6add996cff70e78964f6f3b88afbb65e7c1a683b4d7250919ebbc822001744adcc46b4e1324300823 SHA512 86a515866fa7f33aeb896b9ee67451bdb8d2850a34fcfca719307bacc002e99039fb24e3d6c6f088da1a6e59ca6c71ae764baca4c875e076315852be9100f1b8
EBUILD debugedit-4.16.1.ebuild 1770 BLAKE2B 9657d25e12679c563a0dd2f6220a58844c043f28ead997e6add996cff70e78964f6f3b88afbb65e7c1a683b4d7250919ebbc822001744adcc46b4e1324300823 SHA512 86a515866fa7f33aeb896b9ee67451bdb8d2850a34fcfca719307bacc002e99039fb24e3d6c6f088da1a6e59ca6c71ae764baca4c875e076315852be9100f1b8
MISC metadata.xml 247 BLAKE2B 1750cec57189e711ca5eba89a78e1d317f0839fa53564fbd39b4e955c28d98f4ae04caf9069afc20a18536cdc92b30fe7b15eb086767c742bad07d9980cfd24b SHA512 d6e2ea8a9d74791bcbf3d6311a66bafc20b8f4db3a576d9a8d54b86d7afb231122b8d87f71f3f46360980adf8d815c633b6d5041f9a30fc8656e8fb66057a282
diff --git a/dev-util/debugedit/debugedit-4.16.1.2.ebuild b/dev-util/debugedit/debugedit-4.16.1.2.ebuild
new file mode 100644
index 000000000000..d2c338794406
--- /dev/null
+++ b/dev-util/debugedit/debugedit-4.16.1.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+MY_P=rpm-${PV}
+DESCRIPTION="Stand-alone debugedit from RPM"
+HOMEPAGE="https://rpm.org
+ https://github.com/rpm-software-management/rpm"
+SRC_URI="http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sys-libs/zlib:=
+ >=dev-libs/popt-1.7
+ >=dev-libs/elfutils-0.176-r1
+ dev-libs/nss
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eapply_user
+
+ # cheat it into believing we're bundling db
+ mkdir -p db/dist || die
+ touch db/dist/configure || die
+ chmod +x db/dist/configure || die
+ echo 'install:' > db3/Makefile || die
+
+ # TODO: why do we need to do this?
+ mkdir rpm || die
+ find -name '*.h' -exec cp {} rpm/ ';' || die
+}
+
+src_configure() {
+ append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
+ local myconf=(
+ # force linking to static librpmio
+ --disable-shared
+
+ # disable linking compression libraries
+ ac_cv_header_bzlib_h=no
+ ac_cv_header_lzma_h=no
+ --disable-zstd
+
+ # fake some libraries we don't use
+ ac_cv_header_magic_h=yes
+ ac_cv_lib_magic_magic_open=yes
+
+ # use nss as crypto provider
+ --with-crypto=nss
+
+ # disable other stuff irrelevant to debugedit
+ --disable-bdb
+ --disable-nls
+ --disable-plugins
+ --disable-python
+ --without-acl
+ --without-archive
+ --without-cap
+ --without-external-db
+ --without-hackingdocs
+ --without-lua
+ --without-selinux
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake -C misc
+ emake -C rpmio
+ emake debugedit
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ dobin debugedit
+}