summaryrefslogtreecommitdiff
path: root/dev-util/debugedit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-21 10:20:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-21 10:20:03 +0100
commit6f8038813c460b4f0572d5ef595cdfa94af3a94d (patch)
tree3509e94070265053394b7f2e30a779d7e60c2064 /dev-util/debugedit
parenteccb70a7f91b2d22582587f26d1a28bb31408b45 (diff)
gentoo resync : 21.05.2019
Diffstat (limited to 'dev-util/debugedit')
-rw-r--r--dev-util/debugedit/Manifest1
-rw-r--r--dev-util/debugedit/debugedit-4.14.2-r2.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-util/debugedit/Manifest b/dev-util/debugedit/Manifest
index a3412e91ed4d..507fa00b3b81 100644
--- a/dev-util/debugedit/Manifest
+++ b/dev-util/debugedit/Manifest
@@ -4,4 +4,5 @@ DIST debugedit-5.3.5.tar.bz2 27799 BLAKE2B f81b39122502afe66386b962d0e50e9a16a31
DIST rpm-4.14.2.tar.bz2 4151934 BLAKE2B eb7e32dd736a195f2e5effc184ee8f2c700dcaf80477574c2112b6c96504d86a67c81e611f82ea35ce244e95fad339bd262eb51c35ada5eeffa8d306b6938cb7 SHA512 22e309e8be936e6070430cedd6f5ea0c3871db4c6aadd0d567a9c418796c178c8dd45d44920d7eaa66681790cc2821347affe471cb215d7a490fe7947fbf291c
EBUILD debugedit-0.5.3.5-r1.ebuild 937 BLAKE2B dc741f4fc4f880fffe5775067878d47e357a904acc79bdc69d9d5d7f2f95fcd41f5de34022cf73eb396e9a0d9813ddfe5245724830b069c1cc8d80ab6d462b83 SHA512 7553d4e2fa0ca9c2d65b52636af1ee775eba337bbd7313bb63f6392dd6db140fe81eb513d64b89a4bc07b04b7d80b2f3f24be13b76001f15dff057a7f62de407
EBUILD debugedit-4.14.2-r1.ebuild 1862 BLAKE2B 7298cef549ff97777f748cb871d01d959ed5b680cf693e4c42b0a7826c13d42df121243788f7c965cf56ef2297a00119dcab40a5914315cb1353bf587eb6971f SHA512 951edb87d4e6c55d73d3837140747ce098562787333198ee0cb35c06418b75d4f4e82b54bb6f23c01a0c98cb6999b402ec307fc35e7d78720713dc25d6df919a
+EBUILD debugedit-4.14.2-r2.ebuild 1730 BLAKE2B 565a44267c996a0b9473c5406e5466ab66563f289a75540bc97a1cf80c2ef02f02c21d8a39b810e43a58cfe6aaaa0fe856a66729aa0ec3bc2896f2e305dcfd24 SHA512 a5e08e54e6a406da008cadaed1e5a6f600da1947b3f413aa6ad8700a2c3c6f696504f1231ca3121e280f39469a641f838ea5f8624c63d8923c422aab8949a854
MISC metadata.xml 247 BLAKE2B 1750cec57189e711ca5eba89a78e1d317f0839fa53564fbd39b4e955c28d98f4ae04caf9069afc20a18536cdc92b30fe7b15eb086767c742bad07d9980cfd24b SHA512 d6e2ea8a9d74791bcbf3d6311a66bafc20b8f4db3a576d9a8d54b86d7afb231122b8d87f71f3f46360980adf8d815c633b6d5041f9a30fc8656e8fb66057a282
diff --git a/dev-util/debugedit/debugedit-4.14.2-r2.ebuild b/dev-util/debugedit/debugedit-4.14.2-r2.ebuild
new file mode 100644
index 000000000000..f14f43e3c56b
--- /dev/null
+++ b/dev-util/debugedit/debugedit-4.14.2-r2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+MY_P=rpm-${PV}
+DESCRIPTION="Stand-alone debugedit from RPM"
+HOMEPAGE="http://www.rpm.org
+ https://github.com/rpm-software-management/rpm"
+SRC_URI="http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sys-libs/zlib:=
+ >=dev-libs/popt-1.7
+ >=dev-libs/elfutils-0.176-r1
+ dev-libs/nss
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eapply_user
+
+ # cheat it into believing we're bundling db
+ mkdir -p db/dist || die
+ touch db/dist/configure || die
+ chmod +x db/dist/configure || die
+ echo 'install:' > db3/Makefile || die
+
+ # TODO: why do we need to do this?
+ mkdir rpm || die
+ find -name '*.h' -exec cp {} rpm/ ';' || die
+}
+
+src_configure() {
+ append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
+ local myconf=(
+ # force linking to static librpmio
+ --disable-shared
+
+ # disable linking compression libraries
+ ac_cv_header_bzlib_h=no
+ ac_cv_header_lzma_h=no
+ --disable-zstd
+
+ # fake some libraries we don't use
+ ac_cv_header_magic_h=yes
+ ac_cv_lib_magic_magic_open=yes
+
+ # use nss as crypto provider
+ --with-crypto=nss
+
+ # disable other stuff irrelevant to debugedit
+ --disable-nls
+ --disable-python
+ --without-acl
+ --without-archive
+ --without-cap
+ --without-external-db
+ --without-hackingdocs
+ --without-lua
+ --without-selinux
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake -C misc
+ emake -C rpmio
+ emake debugedit
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ dobin debugedit
+}