summaryrefslogtreecommitdiff
path: root/dev-util/debootstrap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-util/debootstrap
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-util/debootstrap')
-rw-r--r--dev-util/debootstrap/Manifest2
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.124.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/debootstrap/Manifest b/dev-util/debootstrap/Manifest
index 0aec9f94ca4f..c814819e5347 100644
--- a/dev-util/debootstrap/Manifest
+++ b/dev-util/debootstrap/Manifest
@@ -1,4 +1,6 @@
DIST debootstrap_1.0.123.tar.gz 78175 BLAKE2B e507ee76817eef20cfea4e37eaf893f8e64acaa791806ebd55bec97b8e60eb3c59b68bfe5e6023dc6e73706bde2468db46b84f0176ec46d086c3ea9423a206c7 SHA512 3b23f61528d4993750ba22b8765c10cfb9695793177017d9e4faf546da076be6660c5d6e0d1bf30bafe14f6d70f886190d3ec42a0057b895f40e860475eea794
+DIST debootstrap_1.0.124.tar.gz 78498 BLAKE2B ae3075c6eabc1c76fea370ac5781ca0343b0912e03c086f02c011af10ab4c51f2503743705bc0dc52bcf6afeccb97f167802e2034f2182a8c7bb6148fb5d4e0c SHA512 bc028f7fec85b35a5f826044d8aff22b6fdf69e7e2c5f5c95e4b92327bcffa6411b5b21869833d10fb1f70316271149470921ad4310d61fdd3c73b65bd8009f1
DIST devices.tar.gz 47835 BLAKE2B 03bfe097fda12a7a0aa19d3308c0d44382ad945defea05a63b17a72e4051ef94f0e60e75bde35baeace81da59d9f04126f6e463163609475b9c0fdf518f533ef SHA512 994ec8d72e3d52d2d872f7ff0da2336e4cbd3a5fa73bb6cdb9e06f5e7f5b8c69cea639c738fdba1186f382d6dcf62e7746fface664bfbd744aac24b16f034432
EBUILD debootstrap-1.0.123.ebuild 1180 BLAKE2B 69b348fc2fdf6e8e9b19094a96e07417715aace7acaf2b2de8887db50b5edd011ed2456758f800598c3d8dcf3cfb2717bbcb2d5b396b2df1a100e79bfa14cd13 SHA512 a3836cba0337a00133d31ecd93bbabb11976e35dc1a057ed31cec1f2d027cfe0b691cf678074f2b7208ba2519e83fab72144d6fac72d0e3df20f5771d4087e6e
+EBUILD debootstrap-1.0.124.ebuild 1186 BLAKE2B 94f390474378525a9841a835cabfa949c93cc49da839ba506311556fa71d2b77c72aca3544321e76332189095d85695148887f8224ff7286d1f80a5fa84a69d8 SHA512 db1877100e1460bfa858fa7fc6a715dfa8e2ebae0e74d0eb08fcd117138d4599ab7dd491196cd74c3ea3be0bd79a237ad7c2e846151b8f80bc5c40de9209c78a
MISC metadata.xml 251 BLAKE2B e9e9d48943645d8b737bc1f7ab0efb05db0f8eddad759c9bb40d07dc008fbfb8f5cca2020de71a9ff6945f5d66292ac02355773545010cd49c77fe6dd5ab7b40 SHA512 1b6a6955118c1a74cc89a77d6de9be8f4ff9c7137c186753462670a5b93457dfd034ad5d1f4d2507ac95cc149c2a042fa5324220b58702a56b09d91de40151c9
diff --git a/dev-util/debootstrap/debootstrap-1.0.124.ebuild b/dev-util/debootstrap/debootstrap-1.0.124.ebuild
new file mode 100644
index 000000000000..4cc27d3d8911
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.124.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}