summaryrefslogtreecommitdiff
path: root/dev-util/debootstrap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-util/debootstrap
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-util/debootstrap')
-rw-r--r--dev-util/debootstrap/Manifest2
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.116.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/debootstrap/Manifest b/dev-util/debootstrap/Manifest
index 690c767763a7..f3f51bed57f0 100644
--- a/dev-util/debootstrap/Manifest
+++ b/dev-util/debootstrap/Manifest
@@ -1,4 +1,6 @@
DIST debootstrap_1.0.115.tar.gz 75691 BLAKE2B ef2ddd8b76d7eafdf5be50e3cbb99725066562bc4a717ab42b436dcab3e5e3a2148c9e6eeaf7b6135e4bde836ee01101e7158ebc0472c08329ae0152d0845b8b SHA512 635e4feb1fb2bc247968127dc86bf0956243c8058f99e66ede177da84f0258cfc2de51873f347c099217b07e679527aeac08e7263d31b4112fb0708edb3deeb9
+DIST debootstrap_1.0.116.tar.gz 75723 BLAKE2B 3a48e0a51dcd6066af26d036df17e36bb901d7099dfa9521ca86cc1d2d70b8326ad068dd86130de1a2b686a44391d8fd0bcfb78f24cd558777b487f8bdbde699 SHA512 59ba44ecfa7c6bc3d81a814fe66a87223fa4bde24bd986f75875fe9077355a5f4268d822347f99402d4146e81b270a06f21111fb977729f4326bb5b8e017583c
DIST devices.tar.gz 47835 BLAKE2B 03bfe097fda12a7a0aa19d3308c0d44382ad945defea05a63b17a72e4051ef94f0e60e75bde35baeace81da59d9f04126f6e463163609475b9c0fdf518f533ef SHA512 994ec8d72e3d52d2d872f7ff0da2336e4cbd3a5fa73bb6cdb9e06f5e7f5b8c69cea639c738fdba1186f382d6dcf62e7746fface664bfbd744aac24b16f034432
EBUILD debootstrap-1.0.115.ebuild 1170 BLAKE2B 8ce1a0ce29d8a1a930348fa5ec8fb078868514eb478398c4dc7197f3d6b78f7682963783da86b3e2f5fd74a81534b72783c9ae3e7287a1a512c378e43aba3731 SHA512 a08ccf79356784effd1b02369dbd582369fb05c3dbb1b0ec932ebd38295dd3aafd2d65b88fb1997c60d40833aa34b7d84f02258737582968b98c2d3975d21957
+EBUILD debootstrap-1.0.116.ebuild 1179 BLAKE2B e668240a1e791eeac1ae105cd9f23a5b41be0232488364dd84bf719f5fa359d1e0feaff80ce0222a4a7af8bf5863a363bbff9d6f3a53f3d37d85241d41e30b1b SHA512 eb12d2206e869c0e88501317c41e6fe8b98c374de2b1facc345b8244778bc7d771424fadbe2a2fcfca1f8dd21562ea880c98e79acb0e49e5eb5254e6c0762b0d
MISC metadata.xml 258 BLAKE2B c36fff5f8f795a075268afaf56f3ca4d8c75dc6997bd32bf2dade7b1903a27eb31a1f3c248b60fafcf77024a9300e8d0a6f8b5a6ace6aefbbec9374a295c430b SHA512 07739557f72a6f241bb1d2e4f61ca138e5dab6996ccaa4b4072057f0aa3ad2adfdfffe65683becd9d467729efc574bf158d846a8b3a7782cb180a13f0033b6b0
diff --git a/dev-util/debootstrap/debootstrap-1.0.116.ebuild b/dev-util/debootstrap/debootstrap-1.0.116.ebuild
new file mode 100644
index 000000000000..8214beb8d505
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.116.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}