summaryrefslogtreecommitdiff
path: root/dev-util/dbus-test-runner/dbus-test-runner-15.04.0_p100.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/dbus-test-runner/dbus-test-runner-15.04.0_p100.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/dbus-test-runner/dbus-test-runner-15.04.0_p100.ebuild')
-rw-r--r--dev-util/dbus-test-runner/dbus-test-runner-15.04.0_p100.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/dbus-test-runner/dbus-test-runner-15.04.0_p100.ebuild b/dev-util/dbus-test-runner/dbus-test-runner-15.04.0_p100.ebuild
new file mode 100644
index 000000000000..97a40fe0f91f
--- /dev/null
+++ b/dev-util/dbus-test-runner/dbus-test-runner-15.04.0_p100.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+inherit flag-o-matic python-single-r1
+
+DESCRIPTION="Run executables under a new DBus session for testing"
+HOMEPAGE="https://launchpad.net/dbus-test-runner"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.34:2
+ dev-python/dbusmock[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ dev-util/intltool
+"
+# now optional:
+# test? ( dev-util/bustle )
+
+src_prepare() {
+ default
+
+ # bind to specific Python version (with dbusmock installed)
+ sed -i -e "s:python3:${EPYTHON}:" \
+ libdbustest/dbus-mock.c tests/test-libdbustest-mock.c || die
+}
+
+src_configure() {
+ append-flags -Wno-error
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}