summaryrefslogtreecommitdiff
path: root/dev-util/datree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-13 06:09:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-13 06:09:41 +0100
commitd728c1a6db84b373b0b4186e631b2aa407744751 (patch)
treef4f0e051e7af9ed8b1ad13dd9bdb78f66144cc23 /dev-util/datree
parent7a062968f262b368ca164bcd5286dfda1b3f37bc (diff)
gentoo auto-resync : 13:08:2023 - 06:09:40
Diffstat (limited to 'dev-util/datree')
-rw-r--r--dev-util/datree/Manifest4
-rw-r--r--dev-util/datree/datree-1.9.19.ebuild54
-rw-r--r--dev-util/datree/metadata.xml19
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/datree/Manifest b/dev-util/datree/Manifest
new file mode 100644
index 000000000000..d1a7e8d80fac
--- /dev/null
+++ b/dev-util/datree/Manifest
@@ -0,0 +1,4 @@
+DIST datree-1.9.19-deps.tar.xz 76454516 BLAKE2B ddce1505465c2317d52e9c64a0672f8b80e5f2d7dda51279acb624719292c2f6fc1b97c3ab2c3b0e7497a0c20014166afbaf1ba0e1d788ac989c4c0fd6bac140 SHA512 26941c5fedcbaed680a29b81e786a45e89b69e45729c538907718985c17b438fa2079995e3e670107ff23d7bb29d38579b2f9cada20909b2d166c45a782aab9e
+DIST datree-1.9.19.tar.gz 5792718 BLAKE2B 564b3194e424c5396950e4f03ae7c27f9b477afaca4c1f0604202b0f15349307e5f3f70c431227b1e6fcd45f4d323cc3cf990cc12798ccc8887faddf3a1f89dd SHA512 2f962385881d3f5e9a26c2a10c9930c19c090efa2b2ec240610a6cb42a51cc986d3eda92324022cf10f2e583fceadd2d81bb93f7bcddd4cf4b3e871da5d16bdc
+EBUILD datree-1.9.19.ebuild 1051 BLAKE2B c60e4aebf94c221d03c2197f8dd5e5a2b1ee7c391b7f91702353c6753164bda0103a6cf035cd01f32b40b7f280460054f5edef223d038583607703d5136b2149 SHA512 67aed0568e0c8db059a9c3f8fec45b480f2adf1fc1510830f8d6c1144b9bdcd7e544c1b00d47d93914c88c415802cd721990adb23813c32fb359a49b9d64ffbb
+MISC metadata.xml 684 BLAKE2B 7b56274406810bc63dc5ff6d7fb76c0f2f93ca0cf650ee26514b478db2f8e253e339fe4bccb29ffa3902b451c59741a8b67e584726599704c02576fc3bf94c2c SHA512 b082ba2241016873d262867d0f2c4411f08c1e92905e7d33b8d4b10dcab693add150a5588730befb307c0a551efa3880730bd5cb4e262c55e34ca20f89363b40
diff --git a/dev-util/datree/datree-1.9.19.ebuild b/dev-util/datree/datree-1.9.19.ebuild
new file mode 100644
index 000000000000..9444d2a9e96c
--- /dev/null
+++ b/dev-util/datree/datree-1.9.19.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo go-module shell-completion
+
+DESCRIPTION="Tool to ensure K8s manifests and Helm charts follow best practices"
+HOMEPAGE="https://hub.datree.io/
+ https://github.com/datreeio/datree/"
+SRC_URI="
+ https://github.com/datreeio/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md examples )
+
+src_compile() {
+ local go_ldflags="
+ -s
+ -w
+ -X github.com/datreeio/datree/cmd.CliVersion=${PV}
+ "
+ local -a go_buildargs=(
+ -ldflags "${go_ldflags}"
+ )
+ ego build "${go_buildargs[@]}"
+
+ local -a shell_types=(
+ bash
+ fish
+ zsh
+ )
+ local shell_type
+ for shell_type in ${shell_types[@]} ; do
+ edo ./datree completion ${shell_type} > ${PN}.${shell_type}
+ done
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe ${PN}
+
+ dofishcomp ${PN}.fish
+ newbashcomp ${PN}.bash ${PN}
+ newzshcomp ${PN}.zsh _${PN}
+
+ einstalldocs
+}
diff --git a/dev-util/datree/metadata.xml b/dev-util/datree/metadata.xml
new file mode 100644
index 000000000000..dfc2cb26d345
--- /dev/null
+++ b/dev-util/datree/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Datree provides an E2E policy enforcement solution to run automatic checks
+ for rule violations. Datree can be used on the command line, admission
+ webhook, or even as a kubectl plugin to run policies against Kubernetes
+ objects.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/datreeio/datree/issues</bugs-to>
+ <remote-id type="github">datreeio/datree</remote-id>
+ </upstream>
+</pkgmetadata>