summaryrefslogtreecommitdiff
path: root/dev-util/d-spy/d-spy-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-18 00:29:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-18 00:29:05 +0000
commit467e2131896a3030032cd5b0fab2094a045bf9d0 (patch)
tree534578ca7ef61b3eb30fee861db78c0ae58e2fa6 /dev-util/d-spy/d-spy-1.6.0.ebuild
parent1f254b1ee917690b4f8f7738fdcfc295ee304ff7 (diff)
gentoo auto-resync : 18:03:2023 - 00:29:05
Diffstat (limited to 'dev-util/d-spy/d-spy-1.6.0.ebuild')
-rw-r--r--dev-util/d-spy/d-spy-1.6.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/d-spy/d-spy-1.6.0.ebuild b/dev-util/d-spy/d-spy-1.6.0.ebuild
new file mode 100644
index 000000000000..31de818002f3
--- /dev/null
+++ b/dev-util/d-spy/d-spy-1.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="D-spy is a blisteringly fast D-Bus debugger"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/d-spy"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="1"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.68:2
+ >=gui-libs/gtk-4.6:4
+ >=gui-libs/libadwaita-1.0:1
+"
+RDEPEND="
+ ${DEPEND}
+ >=sys-apps/dbus-1
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}