summaryrefslogtreecommitdiff
path: root/dev-util/cucumber-html-formatter/cucumber-html-formatter-16.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /dev-util/cucumber-html-formatter/cucumber-html-formatter-16.0.1-r1.ebuild
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'dev-util/cucumber-html-formatter/cucumber-html-formatter-16.0.1-r1.ebuild')
-rw-r--r--dev-util/cucumber-html-formatter/cucumber-html-formatter-16.0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/cucumber-html-formatter/cucumber-html-formatter-16.0.1-r1.ebuild b/dev-util/cucumber-html-formatter/cucumber-html-formatter-16.0.1-r1.ebuild
new file mode 100644
index 000000000000..aa84e2994ee5
--- /dev/null
+++ b/dev-util/cucumber-html-formatter/cucumber-html-formatter-16.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HTML formatter for Cucumber"
+HOMEPAGE="https://cucumber.io/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-util/cucumber-messages-17.0.1:17
+ !<dev-util/cucumber-html-formatter-13.0.0-r2
+"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "cucumber-messages", "~>17.0"' spec/html_formatter_spec.rb || die
+}