summaryrefslogtreecommitdiff
path: root/dev-util/ctags
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /dev-util/ctags
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'dev-util/ctags')
-rw-r--r--dev-util/ctags/Manifest3
-rw-r--r--dev-util/ctags/ctags-20210321.0.ebuild74
-rw-r--r--dev-util/ctags/ctags-99999999.ebuild74
3 files changed, 151 insertions, 0 deletions
diff --git a/dev-util/ctags/Manifest b/dev-util/ctags/Manifest
index 13b4c99c3a31..38cc22c69e90 100644
--- a/dev-util/ctags/Manifest
+++ b/dev-util/ctags/Manifest
@@ -1,3 +1,6 @@
DIST ctags-20190331.tar.gz 1537104 BLAKE2B 354ddf48cdc9421e70d9d37ec7251e51f7f78564dc4f6236d12e2e18519369c39c22585830fd301b7eff4898d550b824776541198b8c4a31425711776b14fde4 SHA512 414faef7628ecaa66fcd5f172781a32194e1d58637dded1f7e55c138239ad777796bb1510bd447af3ad8243b7178e6f4859139305b0c0efe298182408f34524c
+DIST p5.9.20210321.0.tar.gz 2096441 BLAKE2B 44fcbde5953ac192f8ccb43cbb598b63a99d421feda8fe019bd2ac915fe235a769250bbb2f0f00eb353ce883a7f3556af4dbfc9871fe7fd5fa8edce5f8441af8 SHA512 62d9744bac089106cfa2a477f113ca7924831f768ee0de01577cd11d14f1cd926a246d08a53e7537d1d39c9e8aa06a58b7a10f79d8532326bf0e4af74d70c4ae
EBUILD ctags-20190331.ebuild 1794 BLAKE2B 1c40cdf7fb183989bc0f9e30731dd28b357fa37d717b24603197ae8537d82f7352bd2ff6a727860ca911673a5bbe0816d1ee0c3cf7b50c1f868fc0f3b1900d96 SHA512 a97f1e0eb0c90bc51c7cf339d476fa1b6d7ae484bb3e61a312a750d759f22fdc8d6fbc8b3c39b93c237488bc82ffbe2331ae81335fbcf3b8668f4148fee28b88
+EBUILD ctags-20210321.0.ebuild 1825 BLAKE2B 2a0e097d2626d364c2344db4e72f0c7c2e717f73c3560d2aaf2012c234c3ad858d8f6ca9e543ee48c11a1324f93d6cc5e50d93ef6ae20331b7ca263446cc2a63 SHA512 8463c98b9fb2a0c6b556ab1785f7b128dde90a05dd6a1e765afd146e4d692af7ef88f7ee22294e561fb270a20408137fddb637b72cfb32c73aa1ac56f05bbdfe
+EBUILD ctags-99999999.ebuild 1825 BLAKE2B 2a0e097d2626d364c2344db4e72f0c7c2e717f73c3560d2aaf2012c234c3ad858d8f6ca9e543ee48c11a1324f93d6cc5e50d93ef6ae20331b7ca263446cc2a63 SHA512 8463c98b9fb2a0c6b556ab1785f7b128dde90a05dd6a1e765afd146e4d692af7ef88f7ee22294e561fb270a20408137fddb637b72cfb32c73aa1ac56f05bbdfe
MISC metadata.xml 583 BLAKE2B 32e6225369d82b7aae04a238a314eb77911a38c2d670d4058260b75ced482199b343d1b5d7496bc3a6711b71a429b7205057ab66ed8369083b2533be5a7e0648 SHA512 df8ae31fbbb4546f21c3c06110bc6630f392cbbd937e2ccc3c504e08835e56ac2e7d8156686755217140906cc806001a18627778af0e09d753e50c9a47de28b5
diff --git a/dev-util/ctags/ctags-20210321.0.ebuild b/dev-util/ctags/ctags-20210321.0.ebuild
new file mode 100644
index 000000000000..398cfa10dcb4
--- /dev/null
+++ b/dev-util/ctags/ctags-20210321.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
+HOMEPAGE="https://ctags.io/ https://github.com/universal-ctags/ctags"
+if [[ ${PV} == *99999999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/universal-ctags/ctags"
+else
+ SRC_URI="https://github.com/universal-ctags/ctags/archive/refs/tags/p5.9.${PV}.tar.gz"
+ S="${WORKDIR}/${PN}-p5.9.${PV}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="json xml yaml"
+
+DEPEND="
+ json? ( dev-libs/jansson )
+ xml? ( dev-libs/libxml2:2 )
+ yaml? ( dev-libs/libyaml )
+"
+RDEPEND="
+ ${DEPEND}
+ app-eselect/eselect-ctags
+"
+BDEPEND="
+ dev-python/docutils
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ #./misc/dist-test-cases > makefiles/test-cases.mak || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable json) \
+ $(use_enable xml) \
+ $(use_enable yaml) \
+ --disable-etags \
+ --enable-tmpdir="${EPREFIX}"/tmp
+}
+
+src_install() {
+ emake prefix="${ED}"/usr mandir="${ED}"/usr/share/man install
+
+ # namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # rename ctags to exuberant-ctags (Mandrake does this also).
+ mv "${ED}"/usr/bin/{ctags,exuberant-ctags} || die
+ mv "${ED}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
+}
+
+pkg_postinst() {
+ eselect ctags update
+
+ if [[ -z "$REPLACING_VERSIONS" ]]; then
+ elog "You can set the version to be started by /usr/bin/ctags through"
+ elog "the ctags eselect module. \"man ctags.eselect\" for details."
+ fi
+}
+
+pkg_postrm() {
+ eselect ctags update
+}
diff --git a/dev-util/ctags/ctags-99999999.ebuild b/dev-util/ctags/ctags-99999999.ebuild
new file mode 100644
index 000000000000..398cfa10dcb4
--- /dev/null
+++ b/dev-util/ctags/ctags-99999999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
+HOMEPAGE="https://ctags.io/ https://github.com/universal-ctags/ctags"
+if [[ ${PV} == *99999999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/universal-ctags/ctags"
+else
+ SRC_URI="https://github.com/universal-ctags/ctags/archive/refs/tags/p5.9.${PV}.tar.gz"
+ S="${WORKDIR}/${PN}-p5.9.${PV}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="json xml yaml"
+
+DEPEND="
+ json? ( dev-libs/jansson )
+ xml? ( dev-libs/libxml2:2 )
+ yaml? ( dev-libs/libyaml )
+"
+RDEPEND="
+ ${DEPEND}
+ app-eselect/eselect-ctags
+"
+BDEPEND="
+ dev-python/docutils
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ #./misc/dist-test-cases > makefiles/test-cases.mak || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable json) \
+ $(use_enable xml) \
+ $(use_enable yaml) \
+ --disable-etags \
+ --enable-tmpdir="${EPREFIX}"/tmp
+}
+
+src_install() {
+ emake prefix="${ED}"/usr mandir="${ED}"/usr/share/man install
+
+ # namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # rename ctags to exuberant-ctags (Mandrake does this also).
+ mv "${ED}"/usr/bin/{ctags,exuberant-ctags} || die
+ mv "${ED}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
+}
+
+pkg_postinst() {
+ eselect ctags update
+
+ if [[ -z "$REPLACING_VERSIONS" ]]; then
+ elog "You can set the version to be started by /usr/bin/ctags through"
+ elog "the ctags eselect module. \"man ctags.eselect\" for details."
+ fi
+}
+
+pkg_postrm() {
+ eselect ctags update
+}