summaryrefslogtreecommitdiff
path: root/dev-util/csup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-util/csup
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-util/csup')
-rw-r--r--dev-util/csup/Manifest4
-rw-r--r--dev-util/csup/csup-20060318-r1.ebuild23
-rw-r--r--dev-util/csup/files/csup-20060318-respectflags.patch38
3 files changed, 34 insertions, 31 deletions
diff --git a/dev-util/csup/Manifest b/dev-util/csup/Manifest
index ab9d243af96f..7586ebcbebc4 100644
--- a/dev-util/csup/Manifest
+++ b/dev-util/csup/Manifest
@@ -1,4 +1,4 @@
-AUX csup-20060318-respectflags.patch 1374 BLAKE2B 45f3e110cc6607cf12962daf4d0a00ae831d1b91253c3a7b44be32f5523932a77eec86cdcd8f484d18461df6f4862fdb88cb28c5d8806bb4502968605f5897ff SHA512 e112fd37dae7f037e7700579ab59e8611b5f09f0d8351bd2c909e22e393b05f697a51348fab79ba95d31e28b727e62b4a4ce2f8dc22402ac16efcfa4204a1d8b
+AUX csup-20060318-respectflags.patch 1319 BLAKE2B 1c74a442cb0dcaa68b9e37d67c58b8dd4ac0faf1befd5537ace662740db10ea096ff20a2b71c8f40ef93c0bf76df801977095e0cb66765cfac4944059bc67399 SHA512 555f70f70ea376d7d62794b13dc9594c61c3d9f789234b87af0b295c7679bb028d4b6926fe5d9bb42a6035c2bdf0e0662aab5a09a2c58639456afeac3695e2ff
DIST csup-snap-20060318.tgz 78968 BLAKE2B 9d257e5af438ed784402e427714fc652c5daa403f5cb2240147df5e8c68d2f81eee43da1242b80c82d6bbda3c5534e14c0d6e27ba57442d5b6c34ef1d69ed397 SHA512 60e40f6f903df81b1667af31397978ce99d33b6849dd2476232b325415a391e6840a29e70af85b928a3c7beea55cf3064d3b48d61b9c20c2280dc3f675adcd5a
-EBUILD csup-20060318-r1.ebuild 702 BLAKE2B e6bbb2ad2687b260f527f675628cebf34de2725ae9892e3f17a302a84f0e4aee633e5fd490596e0052ab0974a52f9953a55ececcd9220ba4d7ac99301fdb20d7 SHA512 5047abd39fd2b647ac45a84e1bdc991ec8e8dbcb2adfa65cfb711ee6be337478d1dcf0097132619afc499ee0a5444d436cc76ee20914539a9b599629e0f60165
+EBUILD csup-20060318-r1.ebuild 687 BLAKE2B 8235d6425e9d82cbec09e9d879b7314fedbe1543b2ad4017c5cf38295bea0f61636c45e89ece656fdfbe91469328511883d8fe68d2d445067ee8068156cc480b SHA512 554bde3f74cf04214e76bb6e37ff8017de4bc326d8b77fe01152d3e78b1f0ab3395374a7dac7e3532d047dd60b8872373a54f40ba0c57a3266096c6d8c3b78e5
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/dev-util/csup/csup-20060318-r1.ebuild b/dev-util/csup/csup-20060318-r1.ebuild
index 2c033c7d93ef..109a7dc21dc3 100644
--- a/dev-util/csup/csup-20060318-r1.ebuild
+++ b/dev-util/csup/csup-20060318-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
DESCRIPTION="A rewrite of CVSup"
HOMEPAGE="http://www.mu.org/~mux/csup.html"
@@ -13,31 +13,26 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND="
+RDEPEND="
sys-libs/zlib:0=
dev-libs/openssl:0="
-
-RDEPEND="
- ${DEPEND}"
-
-DEPEND="
- ${DEPEND}
- >=sys-devel/bison-2.1"
+DEPEND="${RDEPEND}"
+BDEPEND=">=sys-devel/bison-2.1"
S="${WORKDIR}/${PN}"
-PATCHES=( "${FILESDIR}/${P}-respectflags.patch")
+PATCHES=( "${FILESDIR}"/${P}-respectflags.patch )
src_compile() {
# unable to work with yacc, but bison is ok.
emake \
CC="$(tc-getCC)" \
- PREFIX=/usr \
+ PREFIX="${EPREFIX}"/usr \
YACC=bison
}
src_install() {
- dobin "${PN}"
- doman "${PN}.1"
+ dobin csup
+ doman csup.1
einstalldocs
}
diff --git a/dev-util/csup/files/csup-20060318-respectflags.patch b/dev-util/csup/files/csup-20060318-respectflags.patch
index c95a974c75ed..541622df5777 100644
--- a/dev-util/csup/files/csup-20060318-respectflags.patch
+++ b/dev-util/csup/files/csup-20060318-respectflags.patch
@@ -1,22 +1,22 @@
-Index: csup/GNUmakefile
-===================================================================
---- csup.orig/GNUmakefile
-+++ csup/GNUmakefile
-@@ -21,7 +21,7 @@ WARNS= -Wall -W -Wno-unused-parameter -W
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -21,22 +21,22 @@
-Wcast-align -Wunused-parameter -Wchar-subscripts -Winline \
-Wnested-externs -Wredundant-decls -Wno-format-y2k
-CFLAGS+= -g -O -pipe -DNDEBUG -I$(PREFIX)/include
-+CFLAGS+= -I$(PREFIX)/include
++CPPFLAGS+= -DNDEBUG -I$(PREFIX)/include
ifeq ($(UNAME), Linux)
- CFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+- CFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++ CPPFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
endif
-@@ -29,14 +29,14 @@ ifeq ($(UNAME), Darwin)
- CFLAGS+= -DHAVE_FFLAGS
+ ifeq ($(UNAME), Darwin)
+- CFLAGS+= -DHAVE_FFLAGS
++ CPPFLAGS+= -DHAVE_FFLAGS
endif
CFLAGS+= $(WARNS)
-LDFLAGS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
-+LIBS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
++LIBS= -lcrypto -lz -lpthread
.PHONY: all clean install
@@ -28,11 +28,19 @@ Index: csup/GNUmakefile
config.c: parse.h
-Index: csup/Makefile
-===================================================================
---- csup.orig/Makefile
-+++ csup/Makefile
-@@ -11,7 +11,7 @@ SRCS= attrstack.c config.c detailer.c di
+@@ -49,9 +49,6 @@
+ clean:
+ rm -f csup $(OBJS) parse.c parse.h token.c csup.1.gz
+
+-%.o: %.c
+- $(CC) $(CFLAGS) -c -o $@ $<
+-
+ %.c: %.y
+ $(YACC) -d -o $@ $<
+
+--- a/Makefile
++++ b/Makefile
+@@ -11,7 +11,7 @@
globtree.c idcache.c keyword.c lister.c main.c misc.c mux.c parse.y \
pathcomp.c proto.c status.c stream.c threads.c token.l updater.c