summaryrefslogtreecommitdiff
path: root/dev-util/csup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/csup
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/csup')
-rw-r--r--dev-util/csup/Manifest4
-rw-r--r--dev-util/csup/csup-20060318-r1.ebuild44
-rw-r--r--dev-util/csup/files/csup-20060318-respectflags.patch43
-rw-r--r--dev-util/csup/metadata.xml8
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-util/csup/Manifest b/dev-util/csup/Manifest
new file mode 100644
index 000000000000..853b89c2578d
--- /dev/null
+++ b/dev-util/csup/Manifest
@@ -0,0 +1,4 @@
+AUX csup-20060318-respectflags.patch 1374 BLAKE2B 45f3e110cc6607cf12962daf4d0a00ae831d1b91253c3a7b44be32f5523932a77eec86cdcd8f484d18461df6f4862fdb88cb28c5d8806bb4502968605f5897ff SHA512 e112fd37dae7f037e7700579ab59e8611b5f09f0d8351bd2c909e22e393b05f697a51348fab79ba95d31e28b727e62b4a4ce2f8dc22402ac16efcfa4204a1d8b
+DIST csup-snap-20060318.tgz 78968 BLAKE2B 9d257e5af438ed784402e427714fc652c5daa403f5cb2240147df5e8c68d2f81eee43da1242b80c82d6bbda3c5534e14c0d6e27ba57442d5b6c34ef1d69ed397 SHA512 60e40f6f903df81b1667af31397978ce99d33b6849dd2476232b325415a391e6840a29e70af85b928a3c7beea55cf3064d3b48d61b9c20c2280dc3f675adcd5a
+EBUILD csup-20060318-r1.ebuild 754 BLAKE2B df091d48f5382631f821da4633af208a8fcc250f13e6e19c420c1f514f17e755f949995c22dbb4daa99e50325be471b8f244346e0b7943eb048b449f573f2263 SHA512 c2257a971cac2266d2b4b197b0d1f08071613c4828eb86a0ec89061765c1c4cf76c75b2f06ff894f1f8c4375299b76566381f2acaedcca3c31be9f800af52852
+MISC metadata.xml 238 BLAKE2B 5d18b211ca67cdae4e0f4d6e1598b20b39a471aa07326791c53bb4e1013607b85bac28a64c1939e53b01228d0c9b7814314b95c0f76928de265d95ef7ee6cd45 SHA512 173efaa53a514acf1e2f0c6681c82a48ec16d505844f551d2cc823ee8685b27837c7461f7956c12182059ee7e83023e2f0bcd5d1afab74beeaf998487193656d
diff --git a/dev-util/csup/csup-20060318-r1.ebuild b/dev-util/csup/csup-20060318-r1.ebuild
new file mode 100644
index 000000000000..4bd23eb5dced
--- /dev/null
+++ b/dev-util/csup/csup-20060318-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A rewrite of CVSup"
+HOMEPAGE="http://www.mu.org/~mux/csup.html"
+SRC_URI="http://mu.org/~mux/csup-snap-${PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+DEPEND="
+ sys-libs/zlib:0=
+ dev-libs/openssl:0="
+
+RDEPEND="
+ ${DEPEND}
+ !>=sys-freebsd/freebsd-ubin-6.2_beta1"
+
+DEPEND="
+ ${DEPEND}
+ >=sys-devel/bison-2.1"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${P}-respectflags.patch")
+
+src_compile() {
+ # unable to work with yacc, but bison is ok.
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX=/usr \
+ YACC=bison
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}
diff --git a/dev-util/csup/files/csup-20060318-respectflags.patch b/dev-util/csup/files/csup-20060318-respectflags.patch
new file mode 100644
index 000000000000..c95a974c75ed
--- /dev/null
+++ b/dev-util/csup/files/csup-20060318-respectflags.patch
@@ -0,0 +1,43 @@
+Index: csup/GNUmakefile
+===================================================================
+--- csup.orig/GNUmakefile
++++ csup/GNUmakefile
+@@ -21,7 +21,7 @@ WARNS= -Wall -W -Wno-unused-parameter -W
+ -Wcast-align -Wunused-parameter -Wchar-subscripts -Winline \
+ -Wnested-externs -Wredundant-decls -Wno-format-y2k
+
+-CFLAGS+= -g -O -pipe -DNDEBUG -I$(PREFIX)/include
++CFLAGS+= -I$(PREFIX)/include
+ ifeq ($(UNAME), Linux)
+ CFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ endif
+@@ -29,14 +29,14 @@ ifeq ($(UNAME), Darwin)
+ CFLAGS+= -DHAVE_FFLAGS
+ endif
+ CFLAGS+= $(WARNS)
+-LDFLAGS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
++LIBS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
+
+ .PHONY: all clean install
+
+ all: csup csup.1.gz
+
+ csup: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $^ $(LIBS)
+
+ config.c: parse.h
+
+Index: csup/Makefile
+===================================================================
+--- csup.orig/Makefile
++++ csup/Makefile
+@@ -11,7 +11,7 @@ SRCS= attrstack.c config.c detailer.c di
+ globtree.c idcache.c keyword.c lister.c main.c misc.c mux.c parse.y \
+ pathcomp.c proto.c status.c stream.c threads.c token.l updater.c
+
+-CFLAGS+= -I. -I${.CURDIR} -g -pthread -DHAVE_FFLAGS -DNDEBUG
++CFLAGS+= -I. -I${.CURDIR} -pthread -DHAVE_FFLAGS
+ WARNS?= 6
+
+ # A bit of tweaking is needed to get this Makefile working
diff --git a/dev-util/csup/metadata.xml b/dev-util/csup/metadata.xml
new file mode 100644
index 000000000000..a00f3aeb1f81
--- /dev/null
+++ b/dev-util/csup/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>bsd@gentoo.org</email>
+ <name>BSD Project</name>
+</maintainer>
+</pkgmetadata>