summaryrefslogtreecommitdiff
path: root/dev-util/csup/csup-20060318-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
commit1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (patch)
treec99a472cce74148d499f42ada873454b0e32a42d /dev-util/csup/csup-20060318-r1.ebuild
parentda6a52f691ef980bab92d003d5df8f463c623af8 (diff)
gentoo resync : 13.03.2018
Diffstat (limited to 'dev-util/csup/csup-20060318-r1.ebuild')
-rw-r--r--dev-util/csup/csup-20060318-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/csup/csup-20060318-r1.ebuild b/dev-util/csup/csup-20060318-r1.ebuild
new file mode 100644
index 000000000000..4bd23eb5dced
--- /dev/null
+++ b/dev-util/csup/csup-20060318-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A rewrite of CVSup"
+HOMEPAGE="http://www.mu.org/~mux/csup.html"
+SRC_URI="http://mu.org/~mux/csup-snap-${PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+DEPEND="
+ sys-libs/zlib:0=
+ dev-libs/openssl:0="
+
+RDEPEND="
+ ${DEPEND}
+ !>=sys-freebsd/freebsd-ubin-6.2_beta1"
+
+DEPEND="
+ ${DEPEND}
+ >=sys-devel/bison-2.1"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${P}-respectflags.patch")
+
+src_compile() {
+ # unable to work with yacc, but bison is ok.
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX=/usr \
+ YACC=bison
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}