summaryrefslogtreecommitdiff
path: root/dev-util/cppunit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-util/cppunit
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/Manifest5
-rw-r--r--dev-util/cppunit/cppunit-1.15.1-r1.ebuild74
-rw-r--r--dev-util/cppunit/cppunit-9999.ebuild43
-rw-r--r--dev-util/cppunit/files/cppunit-1.15.1-slibtool.patch12
4 files changed, 113 insertions, 21 deletions
diff --git a/dev-util/cppunit/Manifest b/dev-util/cppunit/Manifest
index c44b25212626..62312847943d 100644
--- a/dev-util/cppunit/Manifest
+++ b/dev-util/cppunit/Manifest
@@ -1,4 +1,7 @@
+AUX cppunit-1.15.1-slibtool.patch 337 BLAKE2B 7c81687721d0aefe02771e526414df2657707a70c549ad93fb323c3ad6d11a80a60b183ac2ba0f2c1e28a0d8d10dcad2905260bedb7f364feb53a076c165b60b SHA512 23c185bfb2038dc5bee102fac96c9f2fe4763359ee2667de8d98d1513fe5efc1709862099e6376a7f4d0733c38cdd55aa546656efea2331683ecfdbd7533e37c
DIST cppunit-1.14.0.tar.gz 959716 BLAKE2B 581e3b73d6d152c249005ddf267100443e6c9cba12c52c43e9d6f81096b9cd13c3686fa2f73ebaf28c31193e41dbfd5d919dfb0143b190881345da65a5b7f86d SHA512 4ea1da423c6f7ab37e4144689f593396829ce74d43872d6b10709c1ad5fbda4ee945842f7e9803592520ef81ac713e95a3fe130295bf048cd32a605d1959882e
+DIST cppunit-1.15.1.tar.gz 814363 BLAKE2B a1d1d1ee9b6ef408843a6e989a37653944ad85069b4896f18d0f01410acebf7342f70e8c031e58f7ad0e686a85869d521906816e0f0b1762d238efb606cb7310 SHA512 0feb47faec451357bb4c4e287efa17bb60fd3ad966d5350e9f25b414aaab79e94921024b0c0497672f8d3eeb22a599213d2d71d9e1d28b243b3e37f3a9a43691
EBUILD cppunit-1.14.0.ebuild 1692 BLAKE2B 463ebf8ffeb63c9364e87f58edfab50eab27b344ba91f34693e4d6885ee7462cb3684922cceedbcc9a5f76fbd92f2c371776208bc3f235b005a22aef402e67a0 SHA512 e543b16ff04e1abcc9639316b86f68932efd1245b05cd108504869bc3b833584d1e2d4e94ac80a9f79cbbad4da56684f198d107d976402e275a97c3dfb7607f7
-EBUILD cppunit-9999.ebuild 1700 BLAKE2B 568e9d67a0d0d144b52477d6020ecf9f32b0032ab5649989eb5ecf0abdc25ae4115479ffcb6574eb0c5414b2a60d751b0435bfdfd1050b098dd8ae6959d5cfe9 SHA512 958a8856fb24318839c99321c989205fe384b1449b7deb09a9fe38899f7c70481f377838531cabad04fda891e233af680e233de8e1b03a0a2928e736f244affb
+EBUILD cppunit-1.15.1-r1.ebuild 1690 BLAKE2B 3e894991ac9dac6aca42c801d56c171726107dc166e4c3313dc383a7daf2dfd1c4205ce8efed67f26638b1cea4da34f6eb9692adca7ca57ffde473137d813188 SHA512 9eefa19906d8f7df59cf18a152a92ad470a60b27b0092f784d106cef606463506ad1ca3176fa49f656d914519ddad88e4d2b9c085527e882b9c055883a1df391
+EBUILD cppunit-9999.ebuild 1654 BLAKE2B 8357d827f94727e3074f5933a97f64b129710fa77033848fe72dd1e8589d545f381989515805861bd53e988fcd227e8a7cc61adb54b965bce1ea8c8aa991e533 SHA512 63b847b7125ae2e2540879ae4e685b337320260883e27b49f3837c83381ca38450fdfb31d70bc05093ad4aaf7939b25a46ab5db25ec599475d4684973ef5c04f
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/dev-util/cppunit/cppunit-1.15.1-r1.ebuild b/dev-util/cppunit/cppunit-1.15.1-r1.ebuild
new file mode 100644
index 000000000000..8d7448313a9c
--- /dev/null
+++ b/dev-util/cppunit/cppunit-1.15.1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib-minimal
+
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+LICENSE="LGPL-2.1"
+SLOT="0/1.15"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ media-gfx/graphviz
+ )
+"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
+[[ "${PV}" == 9999 ]] || DOCS+=( ChangeLog )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.15.1-slibtool.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Anything else than -O0 breaks on alpha
+ use alpha && replace-flags "-O?" -O0
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(multilib_native_use_enable doc dot)
+ $(multilib_native_use_enable doc doxygen)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ if use doc ; then
+ mv "${ED}"/usr/share/${PN}/html "${ED}"/usr/share/doc/${PF} \
+ || die
+ rm -r "${ED}"/usr/share/${PN} || die
+ fi
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use examples ; then
+ find examples -iname "*.o" -delete
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}
diff --git a/dev-util/cppunit/cppunit-9999.ebuild b/dev-util/cppunit/cppunit-9999.ebuild
index 435544298bf8..a03be99e2df6 100644
--- a/dev-util/cppunit/cppunit-9999.ebuild
+++ b/dev-util/cppunit/cppunit-9999.ebuild
@@ -1,25 +1,26 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
-[[ ${PV} = 9999 ]] && inherit git-r3 autotools
inherit flag-o-matic multilib-minimal
DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit"
-[[ ${PV} = 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/${P}.tar.gz"
-
+if [[ "${PV}" == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
LICENSE="LGPL-2.1"
SLOT="0"
-# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
-[[ ${PV} = 9999 ]] || \
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="doc examples static-libs"
RDEPEND=""
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
doc? (
app-doc/doxygen[dot]
media-gfx/graphviz
@@ -27,11 +28,11 @@ DEPEND="${RDEPEND}
"
DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
-[[ ${PV} = 9999 ]] || DOCS+=( ChangeLog )
+[[ "${PV}" == 9999 ]] || DOCS+=( ChangeLog )
src_prepare() {
default
- [[ ${PV} = 9999 ]] && eautoreconf
+ [[ "${PV}" == 9999 ]] && eautoreconf
}
src_configure() {
@@ -42,22 +43,24 @@ src_configure() {
}
multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(multilib_native_use_enable doc doxygen) \
- $(multilib_native_use_enable doc dot) \
+ local myeconfargs=(
--disable-werror
+ $(multilib_native_use_enable doc dot)
+ $(multilib_native_use_enable doc doxygen)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
- if use doc; then
- mv "${ED%/}"/usr/share/${PN}/html "${ED%/}"/usr/share/doc/${PF} || die
- rm -r "${ED%/}"/usr/share/${PN} || die
+ if use doc ; then
+ mv "${ED}"/usr/share/${PN}/html "${ED}"/usr/share/doc/${PF} \
+ || die
+ rm -r "${ED}"/usr/share/${PN} || die
fi
einstalldocs
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
if use examples ; then
find examples -iname "*.o" -delete
diff --git a/dev-util/cppunit/files/cppunit-1.15.1-slibtool.patch b/dev-util/cppunit/files/cppunit-1.15.1-slibtool.patch
new file mode 100644
index 000000000000..d5bfcb2b7489
--- /dev/null
+++ b/dev-util/cppunit/files/cppunit-1.15.1-slibtool.patch
@@ -0,0 +1,12 @@
+This fixes build with sys-devel/slibtool
+
+--- cppunit-1.15.1/src/cppunit/Makefile.am
++++ cppunit-1.15.1/src/cppunit/Makefile.am
+@@ -62,6 +62,6 @@
+
+ libcppunit_la_LDFLAGS= \
+ -no-undefined -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
+- -release $(LT_RELEASE) $(LIBADD_DL)
++ $(LIBADD_DL)
+
+ libcppunit_la_LIBADD = $(LIBADD_DL)