summaryrefslogtreecommitdiff
path: root/dev-util/cpptest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/cpptest
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/cpptest')
-rw-r--r--dev-util/cpptest/Manifest3
-rw-r--r--dev-util/cpptest/cpptest-1.1.2.ebuild30
-rw-r--r--dev-util/cpptest/metadata.xml16
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/cpptest/Manifest b/dev-util/cpptest/Manifest
new file mode 100644
index 000000000000..b13a56b51dd4
--- /dev/null
+++ b/dev-util/cpptest/Manifest
@@ -0,0 +1,3 @@
+DIST cpptest-1.1.2.tar.gz 458982 BLAKE2B dbb144196ec5726822f859397f5429e743bdc9bd840c2dab198f19512d2d0ff66b33e8b1018be2616944e300b0bc0e2fd247b7c7a5a290096f8d402592f1441b SHA512 da1030c69a5886e752b9ae08b65c501334c7d2d4abd2174190209ce11ed351239a615b9f7c5019ee601289523b2c21a1205d2042e59aea6c2882d77d636fc57a
+EBUILD cpptest-1.1.2.ebuild 585 BLAKE2B 88751b5235040b917f4c0b84064c3e6db41cba60c4daca8405140874359906c8c623008ae88b337e57c27f4e213ba00fd3c56df9819821f5e8c28adb93452763 SHA512 52b488314d202a8e067fa7dc0c6e67c7ff70981109031795288e21aec233c38d5531d79a1ab7b17ca40667b4bbfbb5e5dac11a729e092d1662ef5040b2f5a60d
+MISC metadata.xml 604 BLAKE2B 2d0f5d155ead0d2035142bd395d1d057a4473d6d724b287bf6429a0c120eb340c16e5626929400acde2377b4c34de6fbb3016021f0b759b6fd16265ed67be017 SHA512 7df99419d82f5c714e2c941f810e3a930569045299b63dd9c2eb851628124c410afd30cc1aeac52ddb651e1e48ae8f41727f02c856b0f5a01d16aec318aa82dd
diff --git a/dev-util/cpptest/cpptest-1.1.2.ebuild b/dev-util/cpptest/cpptest-1.1.2.ebuild
new file mode 100644
index 000000000000..b7fa89f0e8d1
--- /dev/null
+++ b/dev-util/cpptest/cpptest-1.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="http://cpptest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+DOCS=( AUTHORS BUGS NEWS README )
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ --htmldir=/usr/share/doc/${PF}/html/
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-util/cpptest/metadata.xml b/dev-util/cpptest/metadata.xml
new file mode 100644
index 000000000000..42e4ae1c3bb8
--- /dev/null
+++ b/dev-util/cpptest/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <longdescription lang="en">
+ CppTest is a portable and powerful, yet simple, unit testing framework for handling
+ automated tests in C++. The focus lies on usability and extendability.
+ Several output formats are supported and new ones are easily added.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">cpptest</remote-id>
+ </upstream>
+</pkgmetadata>