summaryrefslogtreecommitdiff
path: root/dev-util/cookiecutter/cookiecutter-2.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-24 10:33:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-24 10:33:12 +0000
commit0e7b1da874d923b9f006e0000023f5fa528140a8 (patch)
tree5fe8ce29562fb30bd971efe3ae2fedc7f81fed2f /dev-util/cookiecutter/cookiecutter-2.5.0.ebuild
parent9f644c082e09048b176cdc65d87a0e6df3f18f2f (diff)
gentoo auto-resync : 24:11:2023 - 10:33:11
Diffstat (limited to 'dev-util/cookiecutter/cookiecutter-2.5.0.ebuild')
-rw-r--r--dev-util/cookiecutter/cookiecutter-2.5.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/cookiecutter/cookiecutter-2.5.0.ebuild b/dev-util/cookiecutter/cookiecutter-2.5.0.ebuild
new file mode 100644
index 000000000000..d73849c2b159
--- /dev/null
+++ b/dev-util/cookiecutter/cookiecutter-2.5.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
+HOMEPAGE="https://github.com/cookiecutter/cookiecutter"
+SRC_URI="https://github.com/cookiecutter/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/arrow[${PYTHON_USEDEP}]
+ >=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ <dev-python/click-9.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ <dev-python/jinja-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.23.0[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+DOCS=( README.md HISTORY.md CONTRIBUTING.md )
+
+PATCHES=(
+ "${FILESDIR}/test_cli-1.7.2.patch"
+)
+
+distutils_enable_tests pytest
+# TODO: Package sphinx-click
+# distutils_enable_sphinx docs \
+# dev-python/sphinx-rtd-theme \
+# dev-python/recommonmark
+
+python_test() {
+ epytest -o addopts=
+}