summaryrefslogtreecommitdiff
path: root/dev-util/comparator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/comparator
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/comparator')
-rw-r--r--dev-util/comparator/Manifest3
-rw-r--r--dev-util/comparator/comparator-2.10.ebuild39
-rw-r--r--dev-util/comparator/metadata.xml9
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/comparator/Manifest b/dev-util/comparator/Manifest
new file mode 100644
index 000000000000..540241f214cc
--- /dev/null
+++ b/dev-util/comparator/Manifest
@@ -0,0 +1,3 @@
+DIST comparator-2.10.tar.gz 1463175 BLAKE2B 58d6bddc5f785de3768ed2c4845b75af03c1fd7f646fc15efaeec09878a72355c46c64f67866217994797193aaba6d4214685c7be89be9872620dce5930238e8 SHA512 b880f7a4a0fbfad44c53606c6d97509305d8485f0ab76b62bb0d1d1d6d4be9fb81e7a08326e78cabd1a9314e6efbf3a966eb6393e424f59dc657975a63ce2988
+EBUILD comparator-2.10.ebuild 866 BLAKE2B d57e9166f9a0f14ad04c4c2f686198f866699f1ae0eae03a93e256c9d3195bd008844861000b4a45d4b30092be377110067152133d39d07195c3cce705f39682 SHA512 21ed08a933430f6044de705507a60b875786762f9ca413cef8f74814122aeac931676dedd04c3a1b32b7651f9a6f904e878aefe625d4b255d4e84c27d5da0570
+MISC metadata.xml 355 BLAKE2B 012b8c0b8ac6bf274c4d9cdfd496e29e0c2549d98db030508cfb5e546d9e8aac2733cb39a6e7a3e36551472c699b3c7d5e4ad876e88a64397a06f889d5ecc824 SHA512 bfd1f38c1527a5e045c82f58b4f9dd253705e2eaa93bedad1e6c15c470de3ace37862211e647f0c79066c1cc1b0f68f211e26601099e6a802fda053e7ba48d26
diff --git a/dev-util/comparator/comparator-2.10.ebuild b/dev-util/comparator/comparator-2.10.ebuild
new file mode 100644
index 000000000000..d331167b3ead
--- /dev/null
+++ b/dev-util/comparator/comparator-2.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
+HOMEPAGE="http://www.catb.org/~esr/comparator/"
+SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=app-text/docbook-xml-dtd-4.1.2*
+ app-text/xmlto"
+
+src_prepare() {
+ sed \
+ -e '/python setup.py install/d' \
+ -i Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake comparator.html scf-standard.html
+ distutils-r1_src_compile
+}
+
+src_install() {
+ emake ROOT="${D}" install
+ distutils-r1_src_install
+ docinto html
+ dodoc *.html
+}
diff --git a/dev-util/comparator/metadata.xml b/dev-util/comparator/metadata.xml
new file mode 100644
index 000000000000..6ed3edf95f59
--- /dev/null
+++ b/dev-util/comparator/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <longdescription>ESR's utility for making fast comparisons among large source trees</longdescription>
+</pkgmetadata>