summaryrefslogtreecommitdiff
path: root/dev-util/comparator/comparator-2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /dev-util/comparator/comparator-2.12.ebuild
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'dev-util/comparator/comparator-2.12.ebuild')
-rw-r--r--dev-util/comparator/comparator-2.12.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/comparator/comparator-2.12.ebuild b/dev-util/comparator/comparator-2.12.ebuild
new file mode 100644
index 000000000000..bbbbe0a4134a
--- /dev/null
+++ b/dev-util/comparator/comparator-2.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
+HOMEPAGE="http://www.catb.org/~esr/comparator/"
+SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=app-text/docbook-xml-dtd-4.1.2*
+ app-text/xmlto"
+
+src_prepare() {
+ sed \
+ -e '/python setup.py install/d' \
+ -i Makefile || die "sed failed"
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake comparator.html scf-standard.html
+ distutils-r1_src_compile
+}
+
+src_install() {
+ emake ROOT="${D}" install
+ distutils-r1_src_install
+ docinto html
+ dodoc *.html
+}