summaryrefslogtreecommitdiff
path: root/dev-util/colm/colm-0.14.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-29 11:41:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-29 11:41:17 +0000
commit080a6ad2c3759083c02506e1348b689f2194d4eb (patch)
tree2da02928366195f2ad903d29d5a74355f5f8c804 /dev-util/colm/colm-0.14.7.ebuild
parent48f3e81fd35a18cd49f8b8d6a041f33ad88f9c89 (diff)
gentoo auto-resync : 29:02:2024 - 11:41:17
Diffstat (limited to 'dev-util/colm/colm-0.14.7.ebuild')
-rw-r--r--dev-util/colm/colm-0.14.7.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-util/colm/colm-0.14.7.ebuild b/dev-util/colm/colm-0.14.7.ebuild
deleted file mode 100644
index 352487813ce5..000000000000
--- a/dev-util/colm/colm-0.14.7.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools toolchain-funcs
-
-DESCRIPTION="COmputer Language Manipulation"
-HOMEPAGE="https://www.colm.net/open-source/colm/"
-SRC_URI="https://www.colm.net/files/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc"
-
-BDEPEND="
- doc? (
- || ( app-text/asciidoc dev-ruby/asciidoctor )
- dev-python/pygments
- )
-"
-# libfsm moved from ragel -> colm, bug #766108
-RDEPEND="!<dev-util/ragel-7.0.3"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.14.7-drop-julia-check.patch
-)
-
-src_prepare() {
- default
-
- # bug #733426
- sed -i -e 's/(\[ASCIIDOC\], \[asciidoc\], \[asciidoc\]/S([ASCIIDOC], [asciidoc asciidoctor]/' configure.ac || die
-
- # bug #766069
- sed -i -e "s:gcc:$(tc-getCC):" test/colm.d/gentests.sh || die
- sed -i -e "s:g++:$(tc-getCXX):" test/colm.d/gentests.sh || die
-
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable doc manual)
-}
-
-src_test() {
- # Build tests
- default
-
- # Run them
- cd test || die
- ./runtests || die
-}
-
-src_install() {
- default
-
- # NOTE: dev-util/ragel needs the static libraries
- # and .la files, unfortunately.
- # (May have better luck if we use the CMake port?)
-}