summaryrefslogtreecommitdiff
path: root/dev-util/coccinelle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/coccinelle
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/coccinelle')
-rw-r--r--dev-util/coccinelle/Manifest6
-rw-r--r--dev-util/coccinelle/coccinelle-1.0.5.ebuild122
-rw-r--r--dev-util/coccinelle/coccinelle-1.0.6.ebuild124
-rw-r--r--dev-util/coccinelle/files/50coccinelle-gentoo.el6
-rw-r--r--dev-util/coccinelle/metadata.xml12
5 files changed, 270 insertions, 0 deletions
diff --git a/dev-util/coccinelle/Manifest b/dev-util/coccinelle/Manifest
new file mode 100644
index 000000000000..f1efa8c333d7
--- /dev/null
+++ b/dev-util/coccinelle/Manifest
@@ -0,0 +1,6 @@
+AUX 50coccinelle-gentoo.el 154 BLAKE2B debbfe7a00bf6195db370b33430d18fb7121123da26f97c01703704918f977f886090abfa0b6f226f8d713bca566ff6e39fabefb07e098a2bfd7cbd64eaebe6a SHA512 dc99ec43c65fc3b6735b8d06f664c09dabe89bb6dec2a0c0390e97ea2bacb1d76ff33d94124c2a2d1f16795648480c33e0306020e151d67d530e35aa9f4f009d
+DIST coccinelle-1.0.5.tgz 5660596 BLAKE2B 9707e4773d165718b973e004e3359608428d8405d560d7013da66e2b1f0205f003ae0905c02a4f13c9725b39dc94710e5ccbc6b5b11ace66d7e87c3a303363c5 SHA512 0fee450554abc40feac9e745a252c1679f8016c82f04236e642e32e129618a950bb9657f1c447d62543289e95bbd4b1a8b0c6030373025c32a37068f82d30678
+DIST coccinelle-1.0.6.tgz 6684278 BLAKE2B b5b390488e818ce05c364f27782bd1c4dc63657a01c7564764d64faea8ff302c8409bb2ef172ce7ab7c2e00ae1a6f2c3bea76a1148eaf5a977f897d39a9fb23c SHA512 b667762ddf5ad30b126e93572cd8a8b3ffc21a790cd9d6df586e421c5db0a8d049af9587c6e5cb8f7a13f2c090ab2a9cca59ecba69069f9d3fe67b6f75dfe539
+EBUILD coccinelle-1.0.5.ebuild 2532 BLAKE2B 61181f5b7d0c9fc9412fc14ef043f65219318715f586105d75d7e5ea27e0bb95bcfa0870f41f98cebd6e6f30a0636fee8f0b0f46e806a3f743a00d86eba61d12 SHA512 4fc8095cc0c7ac610e5f73bb4bbc5fce144979773fff9047f54dfea8ffdc17c4d8576c9dd90059f778a8ec19f905a61f6ad29ef4a0a68629fedadb4c376751c5
+EBUILD coccinelle-1.0.6.ebuild 2540 BLAKE2B 250bbaff5f571d1ed9130840eebc1382813276ee32134664f9d8130a5d96050857cba62802eaa7f0e3929ff3bd9bc3d47bbc8c03b807f1628ce2b9617c92e576 SHA512 a81263ea8c9bd9323e96df6996bcb311bd6f7ab1a67444efe2c5ebba2f666395af4cdef9b9ddf0353d314ccb8053cb317b6f51f348c6c229cb45554e0d5fd93a
+MISC metadata.xml 350 BLAKE2B 0a338a957b414534b2bc01b9e916a93bc4b17d54b855b23d90f67af7f53a2dddded19eec734bd50edec0130b0b2210869c96c3f8cafe968446dad7d44b76740a SHA512 9c0be4d11897f712a537302f5f87d92cf8df5866e60d3293f5dbf7fe6dd1d88d5678e103319577b397546307604124db39ac47cde7dfb5e61141c43a0fbe5761
diff --git a/dev-util/coccinelle/coccinelle-1.0.5.ebuild b/dev-util/coccinelle/coccinelle-1.0.5.ebuild
new file mode 100644
index 000000000000..e4f865f92b0e
--- /dev/null
+++ b/dev-util/coccinelle/coccinelle-1.0.5.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common
+
+MY_P="${P/_/-}"
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="http://coccinelle.lip6.fr/"
+SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# ocaml enables ocaml scripting (uses findlib)
+CDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/sexplib:=[ocamlopt(+)?]
+ dev-ml/menhir:=[ocamlopt?]
+ dev-ml/camlp4:=[ocamlopt?]
+ dev-ml/parmap:=[ocamlopt?]
+ emacs? ( virtual/emacs )
+ ocaml? ( dev-ml/findlib:= )
+ pcre? ( dev-ml/pcre-ocaml:=[ocamlopt(+)?] )
+ python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="${CDEPEND}
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-fontsextra
+ )"
+
+DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50coccinelle-gentoo.el
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if use python ; then
+ # fix python install location
+ sed -e "s:\$(LIBDIR)/python:$(python_get_sitedir):" \
+ -i Makefile || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ocaml) \
+ $(use_enable pcre) \
+ $(use_enable pcre pcre-syntax) \
+ $(use_enable ocamlopt opt)
+}
+
+src_compile() {
+ emake depend
+
+ if use ocamlopt ; then
+ emake all.opt
+ else
+ emake TARGET_SPATCH=byte-only all-dev
+ fi
+
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts emake docs
+ fi
+
+ if use emacs ; then
+ elisp-compile editors/emacs/cocci.el || die
+ fi
+}
+
+src_test() {
+ emake check
+ use python && emake pycocci-check
+}
+
+src_install() {
+ default
+
+ use doc && dodoc docs/manual/*.pdf
+ newbashcomp scripts/spatch.bash_completion spatch
+
+ if use emacs ; then
+ elisp-install ${PN} editors/emacs/*
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ if use vim-syntax ; then
+ newdoc editors/vim/README README-vim
+ rm editors/vim/README || die
+ insinto /usr/share/vim/vimfiles
+ doins -r editors/vim/*
+ fi
+
+ use python && python_optimize
+
+ export STRIP_MASK='*/coccinelle/spatch'
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/coccinelle/coccinelle-1.0.6.ebuild b/dev-util/coccinelle/coccinelle-1.0.6.ebuild
new file mode 100644
index 000000000000..1e97b0576dc1
--- /dev/null
+++ b/dev-util/coccinelle/coccinelle-1.0.6.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common
+
+MY_P="${P/_/-}"
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="http://coccinelle.lip6.fr/"
+SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# ocaml enables ocaml scripting (uses findlib)
+CDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/sexplib:=[ocamlopt(+)?]
+ dev-ml/menhir:=[ocamlopt?]
+ dev-ml/camlp4:=[ocamlopt?]
+ dev-ml/parmap:=[ocamlopt?]
+ emacs? ( virtual/emacs )
+ ocaml? ( dev-ml/findlib:= )
+ pcre? ( dev-ml/pcre-ocaml:=[ocamlopt(+)?] )
+ python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="${CDEPEND}
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-fontsextra
+ )"
+
+DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50coccinelle-gentoo.el
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if use python ; then
+ # fix python install location
+ sed -e "s:\$(LIBDIR)/python:$(python_get_sitedir):" \
+ -i Makefile || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ocaml) \
+ $(use_enable pcre) \
+ $(use_enable pcre pcre-syntax) \
+ $(use_enable ocamlopt opt)
+}
+
+src_compile() {
+ emake depend
+
+ if use ocamlopt ; then
+ emake all.opt
+ else
+ emake TARGET_SPATCH=byte-only all-dev
+ fi
+
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts emake docs
+ fi
+
+ if use emacs ; then
+ elisp-compile editors/emacs/cocci.el || die
+ fi
+}
+
+src_test() {
+ emake check
+ use python && emake pycocci-check
+}
+
+src_install() {
+ default
+
+ use doc && dodoc docs/manual/*.pdf
+ newbashcomp scripts/spatch.bash_completion spatch
+
+ if use emacs ; then
+ elisp-install ${PN} editors/emacs/*
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ if use vim-syntax ; then
+ newdoc editors/vim/README README-vim
+ rm editors/vim/README || die
+ insinto /usr/share/vim/vimfiles
+ doins -r editors/vim/*
+ fi
+
+ use python && python_optimize
+
+ export STRIP_MASK='*/coccinelle/spatch'
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/coccinelle/files/50coccinelle-gentoo.el b/dev-util/coccinelle/files/50coccinelle-gentoo.el
new file mode 100644
index 000000000000..6721b3c5e5a1
--- /dev/null
+++ b/dev-util/coccinelle/files/50coccinelle-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; site-lisp configuration for coccinelle
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'cocci-mode "cocci" "Major mode for editing cocci code." t)
diff --git a/dev-util/coccinelle/metadata.xml b/dev-util/coccinelle/metadata.xml
new file mode 100644
index 000000000000..9e3f651e48b2
--- /dev/null
+++ b/dev-util/coccinelle/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+</maintainer>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>