summaryrefslogtreecommitdiff
path: root/dev-util/cloc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/cloc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/cloc')
-rw-r--r--dev-util/cloc/Manifest7
-rw-r--r--dev-util/cloc/cloc-1.72.ebuild30
-rw-r--r--dev-util/cloc/cloc-1.74.ebuild30
-rw-r--r--dev-util/cloc/cloc-1.76-r1.ebuild31
-rw-r--r--dev-util/cloc/metadata.xml13
5 files changed, 111 insertions, 0 deletions
diff --git a/dev-util/cloc/Manifest b/dev-util/cloc/Manifest
new file mode 100644
index 000000000000..b03820a2a784
--- /dev/null
+++ b/dev-util/cloc/Manifest
@@ -0,0 +1,7 @@
+DIST cloc-1.72.tar.gz 347245 BLAKE2B 8ce6915322c6cb4682994034525b7c1e3dfa674832c24dd3d3998f3472f83739764aa61beb80ccda51147b663d4555f060b0098fbf307b81418d58ca72b4f14b SHA512 e83567fcc2703b6de761c44d3b85e4c176eaff9f35419a202bd4c00b5cc9160d39251deb762d57b40aacf4fe6322cf79877032ed29abec2a5f00c1abb8d44021
+DIST cloc-1.74.tar.gz 396192 BLAKE2B 632d2e4764a7bec9b6bb45edaac80da65f5ea23ec682c3246beb2add011fa5ac6860671b45981e9eec374872c691e66467bc0d4709b725fa53ec88efc7ce3a05 SHA512 456ff10c50673326e0b80d2e0b5965fba19c5c868e880108647d5182e048e62bdd734ce485386a561163d8dab81551101cbc5dcc13088400fe0a14ad500e1cbf
+DIST cloc-1.76.tar.gz 419678 BLAKE2B bb9ddee89a3efe6d7ea913ddf04a28e4120da82df93ef611f7b19bc9662664787b54a2b063139f8d17db3c69a27f74ff4d2c6263100d68b8d2b92c50ddd2f360 SHA512 3f16f084be1828557e4120a8e41b276336ac240c5de4dc765066277d848ce9af20f31b36ec4beb863066d8b3e9287ea0e0b2a8f1abd15532957f53d2d3935ecd
+EBUILD cloc-1.72.ebuild 652 BLAKE2B 0247613d5209f906c9848d8874d18662cdb103992ece7462434fa2e19a5f12a8bde97b873093eac75ef21132dfe04f5a7fd2f6c22f5893dfa1bd187c2ea85412 SHA512 804fdbb749ec15ff4e68bf4841c8888b8466fedcf88a82d8b82d8968eecde91ccc83582100a4261f9c4731fb01737e828ce3b80a707b6d9410593ea17cd03a00
+EBUILD cloc-1.74.ebuild 655 BLAKE2B b85899b7f270abe0cf86868425e038b47b91ef168d022ab2147a8ccc3b3deb87c93940cc7f0b4a7f184996b2c3651505e37a843b7193f594b780d9d8c38cf09a SHA512 23d7b861f2feecd2e9ae4dbeb7592d039787ec7fb8cb89ca22922275b1e0c46e1fa5d347a91b7d7ebfd47b1023968d593027d26d11569a39e6cbf33a6d827ea9
+EBUILD cloc-1.76-r1.ebuild 675 BLAKE2B a09be83f8551a02a7dfd802b24369b7639f26fa0e4d004a586e8402b37e2e352b3faef463ef328e37979ef0232012f2fd2e4b9057589f4984043898e36fc1aa3 SHA512 c1308b6e3c7e9469e38c10a80848f95eb7f9c802c6751e143202a82b1ae5d543fd403f82126f2bd72f7df5f45e1e5307f4a59bedd1a4587b8af20f982c3514ba
+MISC metadata.xml 435 BLAKE2B 5658cf3e41d5dac9b2acab8075357492429742f12fee07bedec393e3a068d9c57464d7434e044eeacff38bc7a043ecb4b3b6d42d57c0441d27a8f645c599fe0d SHA512 c747ba0f0014099be6572197e6aa9aa520cdfd6bae63fc3e0f92b723554a56180d52e1cb40422a063f56a4003d07b3cd09337b4413471668e62d51a6deace02a
diff --git a/dev-util/cloc/cloc-1.72.ebuild b/dev-util/cloc/cloc-1.72.ebuild
new file mode 100644
index 000000000000..8935ab1749b8
--- /dev/null
+++ b/dev-util/cloc/cloc-1.72.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Count Lines of Code"
+HOMEPAGE="https://github.com/AlDanial/cloc"
+SRC_URI="https://github.com/AlDanial/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Algorithm-Diff
+ dev-perl/Regexp-Common
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp"
+
+src_compile() {
+ pod2man "Unix/${PN}.1.pod" > "${PN}.1" || die
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "Unix/${PN}"
+}
diff --git a/dev-util/cloc/cloc-1.74.ebuild b/dev-util/cloc/cloc-1.74.ebuild
new file mode 100644
index 000000000000..d227ea30905b
--- /dev/null
+++ b/dev-util/cloc/cloc-1.74.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Count Lines of Code"
+HOMEPAGE="https://github.com/AlDanial/cloc"
+SRC_URI="https://github.com/AlDanial/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Algorithm-Diff
+ dev-perl/Regexp-Common
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp"
+
+src_compile() {
+ pod2man "Unix/${PN}.1.pod" > "${PN}.1" || die
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "Unix/${PN}"
+}
diff --git a/dev-util/cloc/cloc-1.76-r1.ebuild b/dev-util/cloc/cloc-1.76-r1.ebuild
new file mode 100644
index 000000000000..70dda680961e
--- /dev/null
+++ b/dev-util/cloc/cloc-1.76-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Count Lines of Code"
+HOMEPAGE="https://github.com/AlDanial/cloc"
+SRC_URI="https://github.com/AlDanial/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Algorithm-Diff
+ dev-perl/Parallel-ForkManager
+ dev-perl/Regexp-Common
+ virtual/perl-Digest-MD5
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long"
+
+src_compile() {
+ pod2man "Unix/${PN}.1.pod" > "${PN}.1" || die
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "Unix/${PN}"
+}
diff --git a/dev-util/cloc/metadata.xml b/dev-util/cloc/metadata.xml
new file mode 100644
index 000000000000..273f73f2439a
--- /dev/null
+++ b/dev-util/cloc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AlDanial/cloc</remote-id>
+ <bugs-to>https://github.com/AlDanial/cloc/issues</bugs-to>
+ <remote-id type="sourceforge">cloc</remote-id>
+ </upstream>
+</pkgmetadata>