summaryrefslogtreecommitdiff
path: root/dev-util/cloc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-util/cloc
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-util/cloc')
-rw-r--r--dev-util/cloc/Manifest4
-rw-r--r--dev-util/cloc/cloc-1.86.ebuild31
-rw-r--r--dev-util/cloc/metadata.xml26
3 files changed, 51 insertions, 10 deletions
diff --git a/dev-util/cloc/Manifest b/dev-util/cloc/Manifest
index be0df66dd421..a5acce655ba0 100644
--- a/dev-util/cloc/Manifest
+++ b/dev-util/cloc/Manifest
@@ -1,3 +1,5 @@
DIST cloc-1.84.tar.gz 514868 BLAKE2B 53fa0f0d2c8033619f9f7202802e5fd51013c459bbeed8482a35050be69981e60f3c96879cc2853d509322933050fda52fe17be7ec393783f06a0df5e9cec785 SHA512 85f8af041b0ca858c21e28d3fb7cd9201264afa9e12bd3a14b15a8af3e6e68378dbb02a39dc12140bcbb104424cf38bfa602d2a0683e8c89fa50cbdcf7556b3a
+DIST cloc-1.86.tar.gz 536828 BLAKE2B f584da0e25ae755a1450117774ec8fdb87eb693ac77473929a52e617713391eb4bffc2f6b74bbcd5b01f6e2c0d747221e3f7c4e74dfd6131d3cde10a3a102daa SHA512 fe6101404f5884d11bf73de43bd25e533b04a70707b95e4e9482b51413aed46ddb55beaa27e3d25cd7604394a739f7cac6c1f8695cd9cab3f23adf6e27171719
EBUILD cloc-1.84.ebuild 681 BLAKE2B 7f0b61c23a9af5fe8bd6d6359e926989191ef28f5a2fe3b045ac325c8c88d3a48d1c3d884e6aa9a35c38ac586a2eb571a9d36d72b8d6215947f1dbc63d5d26a4 SHA512 f5bcfec8a2c440f6105adfb1c9e99acf2b2b5bdfb3f8e1205b4f3c4a92cef7072f472e8337500846bdcd6d88b1c2fb239d61de1c38d6f4e91653127421e5dd6c
-MISC metadata.xml 435 BLAKE2B 5658cf3e41d5dac9b2acab8075357492429742f12fee07bedec393e3a068d9c57464d7434e044eeacff38bc7a043ecb4b3b6d42d57c0441d27a8f645c599fe0d SHA512 c747ba0f0014099be6572197e6aa9aa520cdfd6bae63fc3e0f92b723554a56180d52e1cb40422a063f56a4003d07b3cd09337b4413471668e62d51a6deace02a
+EBUILD cloc-1.86.ebuild 683 BLAKE2B 125b6eb0805bd7047cd3cb74e807a7110393001879aeb9be71b221c3e9369d95e82ed83aab6d7230235e7479c83ecd9030542d9017c9ea529af7fc33350ee594 SHA512 80fffb487795b4abfca524c7a20abf284d8647fbd45c415b0c29ca512beb3edff41fe93e312989690651ba1d61358162b2de51293cb8a7961a8c6d6f4cbd8bbb
+MISC metadata.xml 699 BLAKE2B 424f272c2a398814052cdf40724b0daaf63985ef10194e38b2a22ad4cf67c90a9ee016d7e14dca738729d61b45d0cf7f2044f5801e6b35fe344ab152fe754d80 SHA512 7625ef4e35fda98f4a56ddc5a02f24af4b8a30db9fc1297092188078328ac8c2f188715251b41b3956c40a946b8791c5ec06e71c2edb271ffb0459add56dd7df
diff --git a/dev-util/cloc/cloc-1.86.ebuild b/dev-util/cloc/cloc-1.86.ebuild
new file mode 100644
index 000000000000..61220333dbd9
--- /dev/null
+++ b/dev-util/cloc/cloc-1.86.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Count Lines of Code"
+HOMEPAGE="https://github.com/AlDanial/cloc"
+SRC_URI="https://github.com/AlDanial/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Algorithm-Diff
+ dev-perl/Parallel-ForkManager
+ dev-perl/Regexp-Common
+ virtual/perl-Digest-MD5
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long"
+
+src_compile() {
+ pod2man "Unix/${PN}.1.pod" > "${PN}.1" || die
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "Unix/${PN}"
+}
diff --git a/dev-util/cloc/metadata.xml b/dev-util/cloc/metadata.xml
index 273f73f2439a..dd5229bff56c 100644
--- a/dev-util/cloc/metadata.xml
+++ b/dev-util/cloc/metadata.xml
@@ -1,13 +1,21 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>tamiko@gentoo.org</email>
- <name>Matthias Maier</name>
- </maintainer>
- <upstream>
- <remote-id type="github">AlDanial/cloc</remote-id>
- <bugs-to>https://github.com/AlDanial/cloc/issues</bugs-to>
- <remote-id type="sourceforge">cloc</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>foerster.florianjr@gmail.com</email>
+ <name>Florian Förster</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AlDanial/cloc</remote-id>
+ <bugs-to>https://github.com/AlDanial/cloc/issues</bugs-to>
+ <remote-id type="sourceforge">cloc</remote-id>
+ </upstream>
</pkgmetadata>