summaryrefslogtreecommitdiff
path: root/dev-util/cloc/cloc-1.70.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/cloc/cloc-1.70.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/cloc/cloc-1.70.ebuild')
-rw-r--r--dev-util/cloc/cloc-1.70.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/cloc/cloc-1.70.ebuild b/dev-util/cloc/cloc-1.70.ebuild
new file mode 100644
index 000000000000..3dd2d9910900
--- /dev/null
+++ b/dev-util/cloc/cloc-1.70.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Count Lines of Code"
+HOMEPAGE="https://github.com/AlDanial/cloc"
+SRC_URI="https://github.com/AlDanial/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Algorithm-Diff
+ dev-perl/Regexp-Common
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp"
+
+src_compile() {
+ pod2man "Unix/${PN}.1.pod" > "${PN}.1" || die
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "Unix/${PN}"
+}