summaryrefslogtreecommitdiff
path: root/dev-util/clinfo/clinfo-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /dev-util/clinfo/clinfo-9999.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'dev-util/clinfo/clinfo-9999.ebuild')
-rw-r--r--dev-util/clinfo/clinfo-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/clinfo/clinfo-9999.ebuild b/dev-util/clinfo/clinfo-9999.ebuild
new file mode 100644
index 000000000000..a3dd2fa351bc
--- /dev/null
+++ b/dev-util/clinfo/clinfo-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}