summaryrefslogtreecommitdiff
path: root/dev-util/clazy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-30 06:30:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-30 06:30:40 +0000
commit7d7cc3f0fa58454952dec67b110b41d503bca422 (patch)
tree1a8f98c27530104edbec5993a3ae262b82a25823 /dev-util/clazy
parent0e12f8e53cdddba84b0eb27dca59153e2cf52309 (diff)
gentoo auto-resync : 30:12:2024 - 06:30:40
Diffstat (limited to 'dev-util/clazy')
-rw-r--r--dev-util/clazy/Manifest4
-rw-r--r--dev-util/clazy/clazy-1.13.ebuild83
-rw-r--r--dev-util/clazy/metadata.xml3
3 files changed, 88 insertions, 2 deletions
diff --git a/dev-util/clazy/Manifest b/dev-util/clazy/Manifest
index 8ff12fb81dd9..5138c4d77bd8 100644
--- a/dev-util/clazy/Manifest
+++ b/dev-util/clazy/Manifest
@@ -7,5 +7,7 @@ AUX clazy-1.12-fix-tests-Qt-detect-2.patch 5164 BLAKE2B 7ce4d58f5ca52df4ce229c78
AUX clazy-1.12-llvm-18.patch 1532 BLAKE2B 6527759799a8e99db6c996177f2f4ed9b1fd5f2327b2a950db6138c2bc4dd6c0b8f2d06bc45668836b8a6fc406df0973f9b3f5218361f2d401b7180cb824e308 SHA512 b0666907bb4d023e605b2b8ce4fd9addaa477e87a811d38bdb68c03bdf4a45d52fabb191e300cf3f877eb32189e23b23046c702c11e50527b474d79e4695c2de
AUX clazy-1.12-standalone-install-location.patch 1728 BLAKE2B 9ef38ca69289f767219b7556675f147861725a70a7b94c6c94bbef004c70d714cf08a7e19a0c0ef0d5b6cce812e34fad7072c1de788494a640bc4a536689fd6f SHA512 8b36af55e818658a16108ce92479605a354f56415331d75c0eaf188e998203aa57900bdfca9e69c80d637b2f13424ecd50eafd32b49df86347431e34c3bef562
DIST clazy-1.12.tar.xz 427740 BLAKE2B ad2c78a506132b5fd6b3c22a7e9794c38ddd71242cde6f760e48d0250f6215629007d45303f4b35fdc7717865b8221ab1c2f3c6889a44ea1809e112845f16463 SHA512 7a2b4a753098f15936a4731c82c660c1cd4d81949279435e87f00f7f72bef3e32cb574c8991c0707798581278e9fbcae34d354c1e6b77a15a5e26166d658fa9e
+DIST clazy-1.13.tar.xz 434648 BLAKE2B 2659bec375c9f30021cdd86c12ab4416dfb5250706c2f6254cbd848d07e3e4f220b2a74d23390f235939ad3e5390797ea4b5398948e129a07a66a5de2d33c997 SHA512 4044bddb9e60e227ff2ab7e40c32f087a621e00c985e1706a4f4e2ace20f96cc6e78f00781f7d59da5b066aa49370c645db506e41d955409c0e146771a59ee24
EBUILD clazy-1.12.ebuild 2236 BLAKE2B 03215cae9ffca622db565dcdc09065dd45f3fbb12f99782837a03d4e8ab753bd3a969c25fee389a6157c8fbee532313490df43a12ce4aa3a73cd65a47c2698ec SHA512 3bbd93a7e315c3de2748956ad31ab268d376cb161bd8771b6ff808ef9e6cfe4c2092dd270c366cc50a548367f975d6529b57e0746f172fc383880aea0b24d4df
-MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
+EBUILD clazy-1.13.ebuild 2070 BLAKE2B 5147b9f15115b721fd54c9f8efa64ee3995b4511edfff0834b72ae82878e71fb3e3420226f309e241a0de757803926228e937879e2d5c9f676b66f37e6f9d50f SHA512 e3c39382256b463b9b9782983cd5b185bc25eb8ff6ea4e678bb39773910866a555624171660560d4a3099be52b87ed14f5204a43d52fe66fd129ffac408a4380
+MISC metadata.xml 398 BLAKE2B e4660f76bcd0cb7b8ba5b6b9e6d91b0c82355c79249c55fa0b1158dcc051421be34ebf2c1705404742c788fde6e7833d14de617ec37279c3d43e83a8dcfd6e24 SHA512 2ecc21860dc45936b34f29a3cd2cbd2aa7f7c2475960ec9cf79bd71b5847c961ead38a8046c347d57dbd6461925949d2d1c4f6b4c47185983928b93ffe946328
diff --git a/dev-util/clazy/clazy-1.13.ebuild b/dev-util/clazy/clazy-1.13.ebuild
new file mode 100644
index 000000000000..908a731edf37
--- /dev/null
+++ b/dev-util/clazy/clazy-1.13.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_COMPAT=( {15..19} )
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake llvm-r1 python-any-r1
+
+DESCRIPTION="Compiler plugin which allows clang to understand Qt semantics"
+HOMEPAGE="https://apps.kde.org/clazy"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(llvm_gen_dep 'llvm-core/clang:${LLVM_SLOT}')
+ $(llvm_gen_dep 'llvm-core/llvm:${LLVM_SLOT}')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ ${PYTHON_DEPS}
+ dev-qt/qtbase:6[network,xml]
+ dev-qt/qtmultimedia:6
+ dev-qt/qtnetworkauth:6
+ dev-qt/qtscxml:6[qml]
+ dev-qt/qtsvg:6
+ )
+"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-1.12-LIBRARY_DIRS.patch
+ "${FILESDIR}"/${PN}-1.12-INCLUDE_DIRS.patch
+ "${FILESDIR}"/${PN}-1.12-standalone-install-location.patch
+ "${FILESDIR}"/${PN}-1.12-clazy-install-location.patch
+)
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+ llvm-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e '/install(FILES README.md COPYING-LGPL2.txt checks.json DESTINATION/d' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local -x LLVM_ROOT="$(get_llvm_prefix -d)"
+
+ export CI_JOB_NAME_SLUG="qt6"
+
+ cmake_src_configure
+}
+
+src_test() {
+ # clazy-standalone wants to be installed in the directory of the clang binary,
+ # so it can find the llvm/clang via relative paths.
+ # Requires the standalone-install-location.patch.
+ # Setup the directories and symlink the system include dir for that.
+ local -x LLVM_ROOT="$(get_llvm_prefix -d)"
+ local -x CLANG_ROOT="${LLVM_ROOT//llvm/clang}"
+ mkdir -p "${BUILD_DIR}${CLANG_ROOT}" || die
+
+ ln -s "${CLANG_ROOT}/include" "${BUILD_DIR}${CLANG_ROOT}/include" || die
+
+ # Run tests against built copy, not installed
+ # bug #811723
+ local -x PATH="${BUILD_DIR}/${LLVM_ROOT}/bin:${BUILD_DIR}/bin:${PATH}"
+ local -x LD_LIBRARY_PATH="${BUILD_DIR}/lib"
+
+ chmod +x "${BUILD_DIR}/bin/clazy" || die
+
+ cmake_src_test
+}
diff --git a/dev-util/clazy/metadata.xml b/dev-util/clazy/metadata.xml
index d925f2439758..9d9470cea3bf 100644
--- a/dev-util/clazy/metadata.xml
+++ b/dev-util/clazy/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo KDE Project</name>
</maintainer>
<upstream>
- <bugs-to>https://bugs.kde.org/</bugs-to>
+ <bugs-to>https://bugs.kde.org/enter_bug.cgi?product=clazy</bugs-to>
+ <remote-id type="kde-invent">sdk/clazy</remote-id>
</upstream>
</pkgmetadata>