summaryrefslogtreecommitdiff
path: root/dev-util/cgdb/cgdb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-util/cgdb/cgdb-9999.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-util/cgdb/cgdb-9999.ebuild')
-rw-r--r--dev-util/cgdb/cgdb-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/dev-util/cgdb/cgdb-9999.ebuild b/dev-util/cgdb/cgdb-9999.ebuild
index 75f88b51bff1..416db639d484 100644
--- a/dev-util/cgdb/cgdb-9999.ebuild
+++ b/dev-util/cgdb/cgdb-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/cgdb/cgdb.git"
inherit git-r3
+ EGIT_REPO_URI="https://github.com/cgdb/cgdb.git"
else
SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
@@ -15,16 +15,17 @@ inherit autotools multilib-minimal
DESCRIPTION="A curses front-end for GDB, the GNU debugger"
HOMEPAGE="https://cgdb.github.io/"
+
LICENSE="GPL-2"
SLOT="0"
IUSE="test"
-RESTRICT="!test? ( test )"
+# Tests are broken, need additional research to figure out the cause
+# Bug: https://bugs.gentoo.org/831899
+RESTRICT="test"
DEPEND="
- sys-libs/ncurses:=
+ sys-libs/ncurses:0=
sys-libs/readline:0="
-RDEPEND="${DEPEND}
- sys-devel/gdb"
BDEPEND="
test? (
@@ -32,11 +33,14 @@ BDEPEND="
app-misc/dtach
)"
+RDEPEND="
+ ${DEPEND}
+ sys-devel/gdb"
+
DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
PATCHES=(
- # Bug: #724256
- "${FILESDIR}/${P}-respect-AR.patch"
+ "${FILESDIR}"/${P}-ar.patch
)
src_prepare() {