summaryrefslogtreecommitdiff
path: root/dev-util/cgdb/cgdb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-util/cgdb/cgdb-9999.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-util/cgdb/cgdb-9999.ebuild')
-rw-r--r--dev-util/cgdb/cgdb-9999.ebuild33
1 files changed, 26 insertions, 7 deletions
diff --git a/dev-util/cgdb/cgdb-9999.ebuild b/dev-util/cgdb/cgdb-9999.ebuild
index 5a5dd25473fd..b4fe338de7f7 100644
--- a/dev-util/cgdb/cgdb-9999.ebuild
+++ b/dev-util/cgdb/cgdb-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = *9999* ]]; then
inherit git-r3
@@ -20,24 +20,43 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="test"
-COMMONDEPEND="
+DEPEND="
sys-libs/ncurses:0=
sys-libs/readline:0="
-DEPEND="${COMMONDEPEND}
- test? ( dev-util/dejagnu )"
+BDEPEND="
+ test? (
+ dev-util/dejagnu
+ app-misc/dtach
+ )"
RDEPEND="
- ${COMMONDEPEND}
+ ${DEPEND}
sys-devel/gdb"
-DOCS=( AUTHORS ChangeLog INSTALL NEWS README.md FAQ )
+DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
src_prepare() {
default
./autogen.sh || die
}
+multilib_src_test() {
+ # Tests need an interactive shell, #654986
+
+ # real-time output of the log ;-)
+ touch "${T}/dtach-test.log" || die
+ tail -f "${T}/dtach-test.log" &
+ local tail_pid=${!}
+
+ nonfatal dtach -N "${T}/dtach.sock" \
+ bash -c 'emake check &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'
+
+ kill "${tail_pid}"
+ [[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
+ [[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
+}
+
multilib_src_configure() {
ECONF_SOURCE="${S}" econf
}