summaryrefslogtreecommitdiff
path: root/dev-util/cflow/cflow-1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-util/cflow/cflow-1.7.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-util/cflow/cflow-1.7.ebuild')
-rw-r--r--dev-util/cflow/cflow-1.7.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/cflow/cflow-1.7.ebuild b/dev-util/cflow/cflow-1.7.ebuild
new file mode 100644
index 000000000000..505e9785fbf2
--- /dev/null
+++ b/dev-util/cflow/cflow-1.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="C function call hierarchy analyzer"
+HOMEPAGE="https://www.gnu.org/software/cflow/"
+SRC_URI="http://ftp.gnu.org/gnu/cflow/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug emacs nls"
+
+RDEPEND="emacs? ( >=app-editors/emacs-23.1:* )
+ nls? ( virtual/libintl virtual/libiconv )"
+DEPEND="nls? ( virtual/libintl virtual/libiconv )"
+BDEPEND="emacs? ( >=app-editors/emacs-23.1:* )
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ EMACS=no
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ elisp-compile elisp/cflow-mode.el
+ fi
+}
+
+src_install() {
+ default
+ doinfo doc/cflow.info
+
+ if use emacs; then
+ elisp-install ${PN} elisp/cflow-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}