summaryrefslogtreecommitdiff
path: root/dev-util/cdecl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-util/cdecl
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-util/cdecl')
-rw-r--r--dev-util/cdecl/Manifest7
-rw-r--r--dev-util/cdecl/cdecl-11.11.ebuild36
-rw-r--r--dev-util/cdecl/cdecl-11.12.ebuild36
-rw-r--r--dev-util/cdecl/cdecl-11.14.ebuild36
-rw-r--r--dev-util/cdecl/metadata.xml13
5 files changed, 128 insertions, 0 deletions
diff --git a/dev-util/cdecl/Manifest b/dev-util/cdecl/Manifest
new file mode 100644
index 000000000000..93971a5823b8
--- /dev/null
+++ b/dev-util/cdecl/Manifest
@@ -0,0 +1,7 @@
+DIST cdecl-11.11.tar.gz 765023 BLAKE2B c8847740339f0d9c977c43d9cbf4ea05061a428cef47bfa0cbf908548162eb328483a477e86b60525e39c3e59dc32a21fb093c3afecafb17da1943945c875d98 SHA512 32b95c51af4b1eaa2833777c3a63a807d63f754a766a5dbb215508c11bca99be0b3d3ef260b6bc52a9cbae7f99d82c27fe034f4c9acfcb0447ba1d1c9dba14f4
+DIST cdecl-11.12.tar.gz 766918 BLAKE2B 6cf07cc6e9d4a1948edc4c9ea9eea586624f4117c8871f209270069588644a8f23e7fa98a4d1d80455cfbef392289b5382e36b16b90d16bdacfa136ca05c5198 SHA512 02bf5ea8264025b8fe71dfa166342af2b5a5edd5f85f7d4e106628f5e0dd24641d60a676d84e3337670a3e9fe78829a0433b567e3c6e3ae9698fa64e2eb4ba49
+DIST cdecl-11.14.tar.gz 772235 BLAKE2B 665ac2ab9efb0bb356eb96265e56cc8592534aafe1ada2d6129704b221aed71063645eba8ca9d792b5785127f1e9d4b341157245291f8c1792d04747b8b80043 SHA512 c96f4cd29a8a1e632990dfe13db5a8bd9f0705e1d6899eea5b1b4aa59be7451c1878e1f0a7c618cb051b67f5b99f6ee3ed5c49679cfbd7e723bdece2355f1bf1
+EBUILD cdecl-11.11.ebuild 657 BLAKE2B d82294e5f0a189b09d98b16bd6d2b25ff2a28cc86b92547c545d417b51002c4ef13bdb9f28981ed59a3cf25800b119973e1fe1197f5aa8731d38ba549998c2b7 SHA512 3c5af8de3f740b969f4ccec9bbc9caff44f6fe3a831bb21e6333e685752816552c6343e9804afe2afcf498ba7f057478488eb72c7e22a84f54b09c7351960a79
+EBUILD cdecl-11.12.ebuild 657 BLAKE2B d82294e5f0a189b09d98b16bd6d2b25ff2a28cc86b92547c545d417b51002c4ef13bdb9f28981ed59a3cf25800b119973e1fe1197f5aa8731d38ba549998c2b7 SHA512 3c5af8de3f740b969f4ccec9bbc9caff44f6fe3a831bb21e6333e685752816552c6343e9804afe2afcf498ba7f057478488eb72c7e22a84f54b09c7351960a79
+EBUILD cdecl-11.14.ebuild 657 BLAKE2B d82294e5f0a189b09d98b16bd6d2b25ff2a28cc86b92547c545d417b51002c4ef13bdb9f28981ed59a3cf25800b119973e1fe1197f5aa8731d38ba549998c2b7 SHA512 3c5af8de3f740b969f4ccec9bbc9caff44f6fe3a831bb21e6333e685752816552c6343e9804afe2afcf498ba7f057478488eb72c7e22a84f54b09c7351960a79
+MISC metadata.xml 467 BLAKE2B 5d7d052eccbef208d2973424735e5f1e1c6d94650e90236ab9b75795dca52cf37be6525d168ec8db2a2e1ac8c660960cb731819a95d7ee45d389344ff3215e47 SHA512 4eca67e174c8d132a92352aee85da2fa5e243f8660abd6ff42accb268e54ce6aa5f356d76eea4d2a95b1c487d74b378e1927f24e8be845acc8b5deb08b417a64
diff --git a/dev-util/cdecl/cdecl-11.11.ebuild b/dev-util/cdecl/cdecl-11.11.ebuild
new file mode 100644
index 000000000000..7e715e918523
--- /dev/null
+++ b/dev-util/cdecl/cdecl-11.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION='Composing and deciphering C (or C++) declarations or casts, aka "gibberish."'
+HOMEPAGE="https://github.com/paul-j-lucas/cdecl"
+SRC_URI="https://github.com/paul-j-lucas/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+readline"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ readline? ( sys-libs/readline:0= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with readline)
+}
diff --git a/dev-util/cdecl/cdecl-11.12.ebuild b/dev-util/cdecl/cdecl-11.12.ebuild
new file mode 100644
index 000000000000..7e715e918523
--- /dev/null
+++ b/dev-util/cdecl/cdecl-11.12.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION='Composing and deciphering C (or C++) declarations or casts, aka "gibberish."'
+HOMEPAGE="https://github.com/paul-j-lucas/cdecl"
+SRC_URI="https://github.com/paul-j-lucas/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+readline"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ readline? ( sys-libs/readline:0= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with readline)
+}
diff --git a/dev-util/cdecl/cdecl-11.14.ebuild b/dev-util/cdecl/cdecl-11.14.ebuild
new file mode 100644
index 000000000000..7e715e918523
--- /dev/null
+++ b/dev-util/cdecl/cdecl-11.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION='Composing and deciphering C (or C++) declarations or casts, aka "gibberish."'
+HOMEPAGE="https://github.com/paul-j-lucas/cdecl"
+SRC_URI="https://github.com/paul-j-lucas/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+readline"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ readline? ( sys-libs/readline:0= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with readline)
+}
diff --git a/dev-util/cdecl/metadata.xml b/dev-util/cdecl/metadata.xml
new file mode 100644
index 000000000000..c51407642daa
--- /dev/null
+++ b/dev-util/cdecl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">paul-j-lucas/cdecl</remote-id>
+ <bugs-to>https://github.com/paul-j-lucas/cdecl/issues</bugs-to>
+ <changelog>https://github.com/paul-j-lucas/cdecl/releases</changelog>
+ </upstream>
+</pkgmetadata>