summaryrefslogtreecommitdiff
path: root/dev-util/cdecl/cdecl-14.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 19:30:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 19:30:41 +0100
commit6fe5af3f06c92a6b1a6b21ff5e1bc9d107490971 (patch)
tree872ff7ba355a0b1735779b329c6a6b8b8f728a88 /dev-util/cdecl/cdecl-14.2.ebuild
parente564f1661521043bc9e03e613c3cd8c79d5d7713 (diff)
gentoo auto-resync : 25:06:2023 - 19:30:41
Diffstat (limited to 'dev-util/cdecl/cdecl-14.2.ebuild')
-rw-r--r--dev-util/cdecl/cdecl-14.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/cdecl/cdecl-14.2.ebuild b/dev-util/cdecl/cdecl-14.2.ebuild
new file mode 100644
index 000000000000..b5e991c3c9b0
--- /dev/null
+++ b/dev-util/cdecl/cdecl-14.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION='Composing and deciphering C (or C++) declarations or casts, aka "gibberish."'
+HOMEPAGE="https://github.com/paul-j-lucas/cdecl"
+SRC_URI="https://github.com/paul-j-lucas/cdecl/releases/download/${P}/${P}.tar.gz -> ${P}.release.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug readline ncurses"
+
+DEPEND="
+ ncurses? ( sys-libs/ncurses:0= )
+ readline? ( sys-libs/readline:0= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ econf \
+ $(use_with readline) \
+ $(use_enable ncurses term-size) \
+ $(use_enable debug bison-debug) \
+ $(use_enable debug flex-debug)
+}