summaryrefslogtreecommitdiff
path: root/dev-util/ccls
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-util/ccls
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-util/ccls')
-rw-r--r--dev-util/ccls/Manifest4
-rw-r--r--dev-util/ccls/ccls-0.20190823.5.ebuild40
-rw-r--r--dev-util/ccls/ccls-9999.ebuild40
-rw-r--r--dev-util/ccls/metadata.xml11
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-util/ccls/Manifest b/dev-util/ccls/Manifest
new file mode 100644
index 000000000000..82f325be113f
--- /dev/null
+++ b/dev-util/ccls/Manifest
@@ -0,0 +1,4 @@
+DIST ccls-0.20190823.5.tar.gz 158118 BLAKE2B 09b4a985a284fe74adc408eb9e86094aaf4ebfaf50de3238a17299efabe4749326b8239356c2808ca500a44bef664b2a654e9b16c83c3ef04cd7cf90c56fe3ef SHA512 3c4ecac663eb463870153734fa6206701ede9d72bae3b6eae9c26adab2979ad79d2ac860c1ffb07f8cfcea4aa63afed90510734d91f830c99a86b3811959583f
+EBUILD ccls-0.20190823.5.ebuild 698 BLAKE2B fe14be8fc89c8cbafc63848c833b95e78488c270371d7e82816f798375d77e4b4f4099d3f811e34ca9fa8b607958336e8c613d04afba10b9f59cda9730eccc16 SHA512 f8aee0dd366fbf705e445df84882b516dc6abd09267cdb189745f0f7c7127abd3a92d0a403c81f02b3d5eaa59601f514ba8f98cba274947c5620d9db8177d1be
+EBUILD ccls-9999.ebuild 698 BLAKE2B fe14be8fc89c8cbafc63848c833b95e78488c270371d7e82816f798375d77e4b4f4099d3f811e34ca9fa8b607958336e8c613d04afba10b9f59cda9730eccc16 SHA512 f8aee0dd366fbf705e445df84882b516dc6abd09267cdb189745f0f7c7127abd3a92d0a403c81f02b3d5eaa59601f514ba8f98cba274947c5620d9db8177d1be
+MISC metadata.xml 323 BLAKE2B 0a85191d1996e2f30d149c30bb73ffc49f95600b8a08f5a8ee4a6aede0671d0b14f2de04173e4bb1ba0b9f6e09e79316d1f7de33b490d3ce815b8ab7b29f5f91 SHA512 da5bf276e9237df06298b14f68be2f57ef5ace58aea180623bc896a2f05dd5e6809b0409ac3ffba0e2c26d854b7d3b47f8e47caec0082e9397f5dc4037f549ad
diff --git a/dev-util/ccls/ccls-0.20190823.5.ebuild b/dev-util/ccls/ccls-0.20190823.5.ebuild
new file mode 100644
index 000000000000..d959663fa6f0
--- /dev/null
+++ b/dev-util/ccls/ccls-0.20190823.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit cmake ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-libs/rapidjson
+ sys-devel/clang:=
+ sys-devel/llvm:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_RAPIDJSON=ON
+ )
+ cmake_src_configure
+}
diff --git a/dev-util/ccls/ccls-9999.ebuild b/dev-util/ccls/ccls-9999.ebuild
new file mode 100644
index 000000000000..d959663fa6f0
--- /dev/null
+++ b/dev-util/ccls/ccls-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit cmake ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-libs/rapidjson
+ sys-devel/clang:=
+ sys-devel/llvm:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_RAPIDJSON=ON
+ )
+ cmake_src_configure
+}
diff --git a/dev-util/ccls/metadata.xml b/dev-util/ccls/metadata.xml
new file mode 100644
index 000000000000..73e87fe9d623
--- /dev/null
+++ b/dev-util/ccls/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mattst88@gentoo.org</email>
+ <name>Matt Turner</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">MaskRay/ccls</remote-id>
+ </upstream>
+</pkgmetadata>