summaryrefslogtreecommitdiff
path: root/dev-util/catkin/catkin-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-util/catkin/catkin-9999.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-util/catkin/catkin-9999.ebuild')
-rw-r--r--dev-util/catkin/catkin-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-util/catkin/catkin-9999.ebuild b/dev-util/catkin/catkin-9999.ebuild
index bd0fec4e9fa1..c37940ea8dfe 100644
--- a/dev-util/catkin/catkin-9999.ebuild
+++ b/dev-util/catkin/catkin-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -9,9 +9,9 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/ros/catkin"
fi
-PYTHON_COMPAT=( python3_6 pypy3 )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit ${SCM} cmake-utils python-r1
+inherit ${SCM} cmake-utils python-r1 python-utils-r1
DESCRIPTION="Cmake macros and associated python code used to build some parts of ROS"
HOMEPAGE="http://wiki.ros.org/catkin"
@@ -37,16 +37,18 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] dev-python/mock[${PYTHON_USEDEP}] )"
+BDEPEND="
+ dev-util/cmake
+"
PATCHES=(
"${FILESDIR}/tests.patch"
- "${FILESDIR}/distutils.patch"
"${FILESDIR}/catkin_prefix_path.patch"
"${FILESDIR}/gnuinstalldirs.patch"
"${FILESDIR}/catkin_prefix_path_util_py_v2.patch"
"${FILESDIR}/package_xml.patch"
"${FILESDIR}/etc.patch"
- "${FILESDIR}/sitedir.patch"
+ "${FILESDIR}/egginfo.patch"
)
src_prepare() {
@@ -74,7 +76,7 @@ catkin_src_configure_internal() {
src_configure() {
export PYTHONPATH="${S}/python"
local mycmakeargs=(
- "$(cmake-utils_use test CATKIN_ENABLE_TESTING)"
+ "-DCATKIN_ENABLE_TESTING=$(usex test)"
"-DCATKIN_BUILD_BINARY_PACKAGE=ON"
)
python_foreach_impl catkin_src_configure_internal
@@ -108,6 +110,8 @@ src_install() {
# needed to be considered as a workspace
touch "${ED}/usr/.catkin"
+
+ python_foreach_impl python_optimize
}
pkg_postinst() {