summaryrefslogtreecommitdiff
path: root/dev-util/catkin/catkin-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-util/catkin/catkin-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-util/catkin/catkin-9999.ebuild')
-rw-r--r--dev-util/catkin/catkin-9999.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/dev-util/catkin/catkin-9999.ebuild b/dev-util/catkin/catkin-9999.ebuild
index adf1b136a8c7..46bed14e7929 100644
--- a/dev-util/catkin/catkin-9999.ebuild
+++ b/dev-util/catkin/catkin-9999.ebuild
@@ -11,10 +11,10 @@ fi
PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit ${SCM} cmake-utils python-r1 python-utils-r1
+inherit ${SCM} cmake python-r1 python-utils-r1
DESCRIPTION="Cmake macros and associated python code used to build some parts of ROS"
-HOMEPAGE="http://wiki.ros.org/catkin"
+HOMEPAGE="https://wiki.ros.org/catkin"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
@@ -37,9 +37,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] dev-python/mock[${PYTHON_USEDEP}] )"
-BDEPEND="
- dev-util/cmake
-"
+BDEPEND=""
PATCHES=(
"${FILESDIR}/tests.patch"
@@ -49,7 +47,7 @@ PATCHES=(
"${FILESDIR}/catkin_prefix_path_util_py_v2.patch"
"${FILESDIR}/package_xml.patch"
"${FILESDIR}/etc.patch"
- "${FILESDIR}/egginfo.patch"
+ "${FILESDIR}/gtest.patch"
)
src_prepare() {
@@ -61,7 +59,7 @@ src_prepare() {
-e 's:DESTINATION lib/:DESTINATION ${CMAKE_INSTALL_LIBDIR}/:' \
-e 's:PYTHON_INSTALL_DIR lib:PYTHON_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}:' \
cmake/*.cmake || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
catkin_src_configure_internal() {
@@ -71,7 +69,7 @@ catkin_src_configure_internal() {
-DPYTHON_INSTALL_DIR="${sitedir#${EPREFIX}/usr/}"
)
python_export PYTHON_SCRIPTDIR
- cmake-utils_src_configure
+ cmake_src_configure
}
src_configure() {
@@ -84,17 +82,17 @@ src_configure() {
}
src_compile() {
- python_foreach_impl cmake-utils_src_compile
+ python_foreach_impl cmake_src_compile
}
src_test() {
unset PYTHON_SCRIPTDIR
- python_foreach_impl cmake-utils_src_test
+ python_foreach_impl cmake_src_test
}
catkin_src_install_internal() {
python_export PYTHON_SCRIPTDIR
- cmake-utils_src_install
+ cmake_src_install
if [ ! -f "${T}/.catkin_python_symlinks_generated" ]; then
dodir /usr/bin
for i in "${D}/${PYTHON_SCRIPTDIR}"/* ; do