summaryrefslogtreecommitdiff
path: root/dev-util/catfish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-util/catfish
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest2
-rw-r--r--dev-util/catfish/catfish-4.15.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index 83de53425eb3..981fbfb37c84 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1,3 +1,5 @@
DIST catfish-1.4.13.tar.bz2 221999 BLAKE2B b487947954832c691a5a1b3bd2a49e7ae1aedecbe2084b86b9ae1c8bd7c95f6d3746f80723d351bed3abac0e2396fcce134072345a908f5ba9f0dfebdd95108f SHA512 a90c695e7c1a2172ea7a5f7f1a292e95aa290693a24f3988a68f2fb4597183ff7526c98925fb3ef8517fbca508a1c3853e0de87ec023be9424d994d63e29c886
+DIST catfish-4.15.0.tar.bz2 256897 BLAKE2B 98ac6c1f5af7a48276438c08e0259eaae7f9a7d4f043a8c89b945d1d0a18e10f2faf3a210363cf46a97b4becc7492a6c1ce6b8e499b168729ce18ff80d5da828 SHA512 d2415194e3d803a99b1a0d80763db6f4e95c810d2bc679057e54105bb906ec1a0de32b64d8c0b2a36aad11d689401111c3466b1e8ad41760f4d6b67f979a81a3
EBUILD catfish-1.4.13.ebuild 1128 BLAKE2B baa7858f58e4a1a65806a03482f840896adb5c2d3011981d9d0cc91314c54f3c7196b7eb3699697433690f23ba18ffd84501ca83c1162f5f87ad92457fd193ca SHA512 8cad083f1ab89a1401a12761ab4019c0c9a0b916e4696f6249b332eac1caca81db50c3ff9c51a8b328a733bbd070ef64a0ed544a8d48dc36e058cc73c3aa0a2b
+EBUILD catfish-4.15.0.ebuild 1198 BLAKE2B a21381714e70e071de203b18ed9534050fbfbac84977540228410de8d50c276e7168e815963cae51c866164fffe046926a70722d2840297bbb830e5ebb071df7 SHA512 1b62b7421f44a360af63682da7df7c1a1659a6e894a1384e771a03ff04941b671de569e3bce67bf5603d12c61ddd3bd552389b15118758137f067311d5cf2532
MISC metadata.xml 216 BLAKE2B 9fe308faad3ff5d9aac2a6d04341fe2b775153198ea734e1b17d15eab6b9eb1f781686089a6487ebc2e9cceddfd3f8c4ad1513baaacf931802201aadbe9589f6 SHA512 780eab488d269f38416e3bfc9c02d1a6bc70cee7755ac7cdc9b0bc42a3a50bb8b0b403da139629767d2f0439b15edce7d7b4078a6f528a4e04cecc1aa9bd01e7
diff --git a/dev-util/catfish/catfish-4.15.0.ebuild b/dev-util/catfish/catfish-4.15.0.ebuild
new file mode 100644
index 000000000000..123c750a72e2
--- /dev/null
+++ b/dev-util/catfish/catfish-4.15.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.42
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ x11-libs/pango[introspection]
+ >=xfce-base/xfconf-4.14[introspection]
+ virtual/freedesktop-icon-theme
+"
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ rm -r "${ED}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}