summaryrefslogtreecommitdiff
path: root/dev-util/catfish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-06 15:22:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-06 15:22:56 +0100
commit564f8bfdb74759f8e95ec50a16419425e8ba8f25 (patch)
tree2738b2fbae70ae5b251665eb6da25467f5db050d /dev-util/catfish
parent9b81b8a93760fc1c7d79561adbd7a62c82f334db (diff)
gentoo auto-resync : 06:08:2023 - 15:22:56
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest2
-rw-r--r--dev-util/catfish/catfish-4.18.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index 43e9c062579a..dfa993e1130d 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1,3 +1,5 @@
DIST catfish-4.16.4.tar.bz2 284259 BLAKE2B 97b0cc1f082dc20865a465c282581a23b85df89cc0745d6b69617eee94ff88d04f1e63c1acf64b524345fcbdb1817feda289dc49a57e08b747b2d57388180e40 SHA512 729359e737d5faf8a97caf82d1bc709be46baf76d93f0a7007e27fa96d3f2dfe9e2c316cdba991a38c5333db26c37f18cc4ca7f8468087cad754d44bd1e2677c
+DIST catfish-4.18.0.tar.bz2 295952 BLAKE2B bf05a8f272217936b8f010157c585ab90a9b5858c06a72c6145da62999221725a990d544c67a8469b08d3accbcf28af59bc59a6585e3c8781fb88dc48fb026c0 SHA512 57a3cc5043281bd9527e4faa6a3afcba2e8948fb6dc9e8d93d26ceb0358a84850b3e892105f81b4f2a30bb2964d65b2083fd07b55f145f3ae6ea653acd098539
EBUILD catfish-4.16.4.ebuild 1178 BLAKE2B 15967a7c0c722395cb6468d1d58010e4b3c880e21181661ea0fd7378cbb177cf04d6dd4d2f8dc6198d101378373f01e0e04d100dc5b3c4cca8ed4d780d904b69 SHA512 8c0c05534f3222d2b5d95475112e43dcec5ba76ce00ee472eed95b92d129b0ce095e0176c51bb9b3a7eade589240c34c6afcec2c85c40a82081871ca011d3774
+EBUILD catfish-4.18.0.ebuild 1181 BLAKE2B 7efeb76f3ab151acb50856073c7bdeebabc8d12a2315becb39ea0d786e62dbdac1e45a4d308eaac8f95aaac774e144935041cd3207e4a4c9882398792ebbd81b SHA512 eddcb596880fd9cf08413ed332594b116604833aa7d304c6f320bb98c83ba2d97a81e20b3b27e14eb70a33a0e64f458688b4f48fd70312f2bff78993528308d5
MISC metadata.xml 217 BLAKE2B dbd6f28308a539b2f2d27b9b2bb6d44ce324db803a3ed7218ac091711f3cfcd5f01f505c084c0b714f19257af70483906135c68caa1964252b6a9c9fe71b4ac7 SHA512 ba66b524e0287ac4326c527d973ed2ff6a40e330f38f3f1333db2c66a7672e6b24a6212ddf430ee454ed943d89d04a12e42eb670f3dcf1567f59c6e51d5677aa
diff --git a/dev-util/catfish/catfish-4.18.0.ebuild b/dev-util/catfish/catfish-4.18.0.ebuild
new file mode 100644
index 000000000000..9f39a9e09cbe
--- /dev/null
+++ b/dev-util/catfish/catfish-4.18.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.42
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ x11-libs/pango[introspection]
+ >=xfce-base/xfconf-4.14[introspection]
+ virtual/freedesktop-icon-theme
+"
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+src_install() {
+ distutils-r1_src_install
+ rm -r "${ED}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}