summaryrefslogtreecommitdiff
path: root/dev-util/catfish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-util/catfish
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-4.16.3-r1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index 98614508fa88..857298271e27 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1,3 +1,4 @@
DIST catfish-4.16.3.tar.bz2 271642 BLAKE2B cebadeeb478a041ba6f815aec81b18d317ebf468bfe0699e33c4550a2f4b1b3377cbabd08d7d6504c3d94169b2be68d35ade9bd77e018ea7c099370ccf4ac124 SHA512 23ffa160b0593033a9696644fd00c48e4a6f54dc25448f975f0949aece50d8e4fbb45b9ad086a8e14072ac1dab27e0b4ecd19af0f31a5b4a775b17e18b00c7bb
+EBUILD catfish-4.16.3-r1.ebuild 1180 BLAKE2B 0479546432b141c4155f2d72596816991410f145d1baed7cc42444b03c8c04a42c6e9b9272e9afdbf37069c90e0f02b9ccf1d11e0cced8b56d59f17964691838 SHA512 42145be4ca3c5ee4b2bb7be7a482e3fa3778d94d753d8b8bbbc380288fc3c9c092c25d0f4d3843e971d930870ae9112abe29d88644bafae65d19a319ca971051
EBUILD catfish-4.16.3.ebuild 1197 BLAKE2B 085361e1637e506cdccb07c50464fbb7e2ecbbc6517c0ede48907100f3764f787b98bbc452a7f5b179f5bb30e20197c62078dd28f72e458bee5265370d550a05 SHA512 27d63ea3fba37a90fc0b0e78f7a2e8133fb6a5c74890bd26958f261f219236e4038b13a0eb14a814b874d727cfbca0efaf3e9d44ca72d02d065bf1cc1232b9a7
MISC metadata.xml 217 BLAKE2B dbd6f28308a539b2f2d27b9b2bb6d44ce324db803a3ed7218ac091711f3cfcd5f01f505c084c0b714f19257af70483906135c68caa1964252b6a9c9fe71b4ac7 SHA512 ba66b524e0287ac4326c527d973ed2ff6a40e330f38f3f1333db2c66a7672e6b24a6212ddf430ee454ed943d89d04a12e42eb670f3dcf1567f59c6e51d5677aa
diff --git a/dev-util/catfish/catfish-4.16.3-r1.ebuild b/dev-util/catfish/catfish-4.16.3-r1.ebuild
new file mode 100644
index 000000000000..4f81700a37f0
--- /dev/null
+++ b/dev-util/catfish/catfish-4.16.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.42
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ x11-libs/pango[introspection]
+ >=xfce-base/xfconf-4.14[introspection]
+ virtual/freedesktop-icon-theme
+"
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+src_install() {
+ distutils-r1_src_install
+ rm -r "${ED}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}