summaryrefslogtreecommitdiff
path: root/dev-util/catfish/catfish-1.4.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
commita1392efe64137262023d92492396ca9156d22396 (patch)
treede438b2711c7697c4597fb04f07e988586f34233 /dev-util/catfish/catfish-1.4.10.ebuild
parente3cf2c86fca1750343c1885311f857f185ee4f2d (diff)
gentoo resync : 13.09.2019
Diffstat (limited to 'dev-util/catfish/catfish-1.4.10.ebuild')
-rw-r--r--dev-util/catfish/catfish-1.4.10.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/catfish/catfish-1.4.10.ebuild b/dev-util/catfish/catfish-1.4.10.ebuild
new file mode 100644
index 000000000000..8833b3e29740
--- /dev/null
+++ b/dev-util/catfish/catfish-1.4.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ virtual/freedesktop-icon-theme
+"
+DEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ rm -r "${ED%/}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}