summaryrefslogtreecommitdiff
path: root/dev-util/catalyst/catalyst-3.0.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 02:54:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 02:54:37 +0000
commit2c4066122b66fa1eb3e37846f9a6e14529a553d8 (patch)
treed33f0181902cea4ff2df3da927ba0309c0ee7ede /dev-util/catalyst/catalyst-3.0.22.ebuild
parent896d6a8a88861c42b5d531a2f147c8a29a149bd8 (diff)
gentoo auto-resync : 02:12:2022 - 02:54:37
Diffstat (limited to 'dev-util/catalyst/catalyst-3.0.22.ebuild')
-rw-r--r--dev-util/catalyst/catalyst-3.0.22.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-util/catalyst/catalyst-3.0.22.ebuild b/dev-util/catalyst/catalyst-3.0.22.ebuild
deleted file mode 100644
index 282eccf985ea..000000000000
--- a/dev-util/catalyst/catalyst-3.0.22.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} == *9999* ]]; then
- SRC_ECLASS="git-r3"
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/catalyst.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://gitweb.gentoo.org/proj/catalyst.git/snapshot/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1 ${SRC_ECLASS}
-
-DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Catalyst"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="ccache doc +iso system-bootloader"
-
-DEPEND="
- app-text/asciidoc
- >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
- dev-python/fasteners[${PYTHON_USEDEP}]
-"
-RDEPEND="
- >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
- dev-python/fasteners[${PYTHON_USEDEP}]
- >=dev-python/pydecomp-0.3[${PYTHON_USEDEP}]
- app-arch/lbzip2
- app-crypt/shash
- sys-fs/dosfstools
- || (
- app-arch/tar[xattr]
- app-arch/libarchive[xattr]
- )
- amd64? ( >=sys-boot/syslinux-3.72 )
- x86? ( >=sys-boot/syslinux-3.72 )
- ccache? ( dev-util/ccache )
- iso? ( app-cdr/cdrtools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
-"
-PDEPEND="system-bootloader? ( >=sys-apps/memtest86+-5.01-r4
- sys-boot/grub:2
- amd64? ( sys-boot/grub[grub_platforms_efi-32,grub_platforms_efi-64] )
- x86? ( sys-boot/grub[grub_platforms_efi-32] )
- sys-boot/syslinux
- sys-boot/shim )"
-
-python_prepare_all() {
- python_setup
- echo VERSION="${PV}" "${PYTHON}" setup.py set_version
- VERSION="${PV}" "${PYTHON}" setup.py set_version || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # build the man pages and docs
- emake
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc; then
- dodoc files/HOWTO.html files/docbook-xsl.css
- fi
-}