summaryrefslogtreecommitdiff
path: root/dev-util/bustle/bustle-0.4.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/bustle/bustle-0.4.7-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/bustle/bustle-0.4.7-r1.ebuild')
-rw-r--r--dev-util/bustle/bustle-0.4.7-r1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-util/bustle/bustle-0.4.7-r1.ebuild b/dev-util/bustle/bustle-0.4.7-r1.ebuild
new file mode 100644
index 000000000000..3f1b1336bc15
--- /dev/null
+++ b/dev-util/bustle/bustle-0.4.7-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Draw pretty sequence diagrams of D-Bus traffic"
+HOMEPAGE="http://hackage.haskell.org/package/bustle"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ net-libs/libpcap
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/pango
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ dev-haskell/cairo
+ >=dev-haskell/dbus-0.10
+ dev-haskell/glib
+ >=dev-haskell/gtk-0.13
+ >=dev-haskell/hgettext-0.1.5
+ dev-haskell/mtl
+ >=dev-haskell/pango-0.13
+ dev-haskell/parsec
+ dev-haskell/pcap
+ dev-haskell/setlocale
+ dev-haskell/text
+ >=dev-lang/ghc-6.12.1
+ virtual/pkgconfig
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gtk-0.13.patch
+}
+
+src_compile() {
+ # compile haskell part
+ cabal_src_compile || die "could not build haskell parts"
+
+ # compile C part
+ emake \
+ "CC=$(tc-getCC)" \
+ "CFLAGS=${CFLAGS}" \
+ "CPPFLAGS=${CPPFLAGS}" \
+ "LDFLAGS=${LDFLAGS}"
+}
+
+src_install() {
+ # install haskell part
+ cabal_src_install || die "could not install haskell parts"
+
+ dobin "${S}"/dist/build/bustle-pcap
+ doman bustle-pcap.1
+ dodoc README HACKING NEWS
+}