summaryrefslogtreecommitdiff
path: root/dev-util/buildbot/buildbot-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-util/buildbot/buildbot-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-util/buildbot/buildbot-9999.ebuild')
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index bb6920d8ce96..dcf36e3727e7 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
PYTHON_REQ_USE="sqlite"
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
EGIT_REPO_URI="https://github.com/buildbot/${PN}.git"
@@ -32,11 +32,13 @@ RDEPEND="
>=dev-python/twisted-17.9.0[${PYTHON_USEDEP},crypt?]
>=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-1.4.0[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-migrate-0.13[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
>=dev-python/txaio-2.2.2[${PYTHON_USEDEP}]
dev-python/pyjwt[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/unidiff[${PYTHON_USEDEP}]
>=dev-python/zope-interface-4.1.1[${PYTHON_USEDEP}]
~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
crypt? (
@@ -64,6 +66,7 @@ DEPEND="${RDEPEND}
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
)
test? (
+ dev-python/ldap3[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
dev-python/moto[${PYTHON_USEDEP}]
>=dev-python/boto3-1.12.48[${PYTHON_USEDEP}]
@@ -94,10 +97,10 @@ src_compile() {
if use doc; then
einfo "Generation of documentation"
- pushd docs > /dev/null
+ pushd docs > /dev/null || die
#'man' target is currently broken
emake html
- popd > /dev/null
+ popd > /dev/null || die
fi
}