summaryrefslogtreecommitdiff
path: root/dev-util/buildbot-www-react
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 11:49:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 11:49:23 +0000
commit840a65e2af3f2cc7527e723a28f6e627a9592fb7 (patch)
tree66e124d9e55317fe43e1af9984e75c156df5cb29 /dev-util/buildbot-www-react
parent73e3b099187df1c4f2df056e45f345a56d2535aa (diff)
gentoo auto-resync : 30:01:2024 - 11:49:23
Diffstat (limited to 'dev-util/buildbot-www-react')
-rw-r--r--dev-util/buildbot-www-react/Manifest2
-rw-r--r--dev-util/buildbot-www-react/buildbot-www-react-3.11.0.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/buildbot-www-react/Manifest b/dev-util/buildbot-www-react/Manifest
index 4893c4ba8a12..8f8c5d9f4f82 100644
--- a/dev-util/buildbot-www-react/Manifest
+++ b/dev-util/buildbot-www-react/Manifest
@@ -1,3 +1,5 @@
+DIST buildbot-www-react-3.11.0.tar.gz 339509 BLAKE2B 274ac1e27537fb10918720dee4ca017289741c4da49c24af25cdb9ce342dccdc61e1b03d669521a8aa54e9265eefdead062869f0db1176d2ea9de5d147d2459b SHA512 3f110a9195f6a1206392f54f78bc82e4a17a386fed2316ae94f5a6648bde7603e948453161f80018064a403c661fcddceaf57c1c480527f0b7ae9e5906e714af
DIST buildbot-www-react-3.9.0.tar.gz 38431 BLAKE2B e32edbd846c131670f8bc3c84fbc9456bd5757a09ed1e3b145f8cbb13707a31866527b3d1d16b7d77a2cf05d90923037841034c835ba5d7bc92ee47d9a00be92 SHA512 bdc1db5a21ff47b8f8c416e1eae38b561b2480d7643b91b598ae25bf6ffa362e6eeadf90c6a0e109dca6b80c15400562529d7b4dfe9e0ed1588e33a69b8c132f
+EBUILD buildbot-www-react-3.11.0.ebuild 617 BLAKE2B 4ea5b13488102e13d467026d3552a6b5ad2189e880eb0e3ccdad99120bd1436129362e7d4666d8a01eb1030b98c4104dd7621505f1158fcf95f8fce2329c0cfd SHA512 fc40b5dc77ad9bc61d1d816d0ddd9da308d5dc817fe7d6377d1f26cebabe8386b52bdff7a8c8e23c95f63075272a4853143466dee3adc18f349610cb4145ebf0
EBUILD buildbot-www-react-3.9.0.ebuild 624 BLAKE2B a4f3ec7e873318f873c6b2f6e42ca080c2065dd2ec710f62c74f52973641170c270aba6fe661b8212465b660abfc55ae54b4049760e35b30eec0b721ea346bac SHA512 15f0934a7d74855d39ab462c2d69ec42a8be3b558da1e3097aeccf4e7eeb3f7fece05a176b43c0df748aa9e5db32b001d787af65d7034c55e78270751936e70a
MISC metadata.xml 794 BLAKE2B b924538a54cfdf084312cef30854b5000ceac6bfe2f0fabf945642f7aedf78970741d352ee0405be9f2db6c922e81ff2539e4abfa392737439c90e469c38bb64 SHA512 5ae2d44f39f61e8189d3def94f6cf7a54503f663b21ccdc9a9fdf0fd7ca2c0f8fb02506da84f1ea7bde76ed00d8286c09fd10dad07eddf870b3d9948dc763455
diff --git a/dev-util/buildbot-www-react/buildbot-www-react-3.11.0.ebuild b/dev-util/buildbot-www-react/buildbot-www-react-3.11.0.ebuild
new file mode 100644
index 000000000000..278991d26bc3
--- /dev/null
+++ b/dev-util/buildbot-www-react/buildbot-www-react-3.11.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-react-{console-view,grid-view}..."
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-www-react/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+RDEPEND="~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"