summaryrefslogtreecommitdiff
path: root/dev-util/buildbot-wsgi-dashboards
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-util/buildbot-wsgi-dashboards
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-util/buildbot-wsgi-dashboards')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest2
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.4.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index 5c2abd7f7201..fa8f5037b364 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1,3 +1,5 @@
DIST buildbot-wsgi-dashboards-2.8.2.tar.gz 5566 BLAKE2B 487b816862366acae9e55c39cb440a21c8e5c438299c43e2d6fad049ff946ece5ab647390955fbbad403ad1d7c0a2707a7612129442dc398cc7210d831aa49ef SHA512 2b75a61331aa457b3f168e1955b8905f95d11008ab6bee611ac92488f988cb0cf73fbf92321e594ac0a6e5ae03b82dfa05daab5a0647ae636a96922c0f4e8eff
+DIST buildbot-wsgi-dashboards-2.8.4.tar.gz 5588 BLAKE2B 3298edaebe2f9eb5e31f8298598e892d64d653648843e3c107710d4df3a24977bd3e77db06f7edecdf8d85bbbdeedfc66a75c6f3eef93ec8374d0df1973790dc SHA512 656f0626c8cad2c21d64ebc3eb4d6e1ac24a10909afc28819e54046be8e843a7383f3648a00a908cfddd9543767e1c3293825170d7c6c64c40a61bdcd55245bd
EBUILD buildbot-wsgi-dashboards-2.8.2.ebuild 783 BLAKE2B e86d4cd37741844a6a73194d8dbf87940cc4002db9d29f1d533d9be8f085e051d625369ae2ca4139c70e23e7feceff253c34a3cb659b18138546ac9fba5d6f59 SHA512 2341b355fb3868fc0f488c9a8b378e67b0e9ffcfa973628f235686467623f50c57d1e554f3781ea476a77dcf580bc3399e53d110cd39bd9a364ed83fc1c39884
+EBUILD buildbot-wsgi-dashboards-2.8.4.ebuild 783 BLAKE2B e86d4cd37741844a6a73194d8dbf87940cc4002db9d29f1d533d9be8f085e051d625369ae2ca4139c70e23e7feceff253c34a3cb659b18138546ac9fba5d6f59 SHA512 2341b355fb3868fc0f488c9a8b378e67b0e9ffcfa973628f235686467623f50c57d1e554f3781ea476a77dcf580bc3399e53d110cd39bd9a364ed83fc1c39884
MISC metadata.xml 679 BLAKE2B 9ce30ea17fc3c2fa7f7c4fba8ad2f521bdf828662683893a8b6e8fc43f4c1ce8fcd8afdb1bc237153751eeb5d134df683b1abe9f0bf7a70f1b6c98517640d3b9 SHA512 47cebf0aa635cee9157445057c21b2d1272b222291874371791656823f75b20f59772ebae2eb1dd8230752808878f284879127650f7130e2b9820ce60fc6d92b
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.4.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.4.ebuild
new file mode 100644
index 000000000000..f124a0ef5c54
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-2.8.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-wsgi-dashboards/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"