summaryrefslogtreecommitdiff
path: root/dev-util/buildbot-wsgi-dashboards
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /dev-util/buildbot-wsgi-dashboards
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'dev-util/buildbot-wsgi-dashboards')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest2
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-0.9.12.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index bfe6341a3b64..04d4c30d8191 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1,3 +1,5 @@
DIST buildbot-wsgi-dashboards-0.9.11.tar.gz 627215 SHA256 bb72b78045867bc0ee2cbe90df96978860ed14e61090dc67b5ecd9606bab2975 SHA512 6f829d5ead05cb91f5b85f128874f1df01288e87938df9f8dd1cca1552ccfb7cae35be4eb077ea97d5ca4f44b236947649131b9aed2bdc9142920c2ee1439f4b WHIRLPOOL d33937eb54c8c4f7bc8d5d3258d37b0fac39293657e2668fc96149a574ff583f37798ff0ce03b2bc5a2ab5db1015db5538c1d5806ff23ca7d2b7a8152666d97f
+DIST buildbot-wsgi-dashboards-0.9.12.tar.gz 627274 SHA256 6feaa8018ea4a16edefa3fa6ea48fa40a37ed374226473cf7a79369f599f9599 SHA512 113c1616b08feb64fd3d94c1186e3d7dd7ea93e563a96ddb802e6ff8135e194014464ef09a23004518451626584bc531fc17419188ebbdd388e9363541b80c3d WHIRLPOOL 6a3b07bd131f84ed13b940c19ca6680d76967135e50d53fb1da9115511707200ac322adc59ae4a3f36928f00903137df44fa012aa3f097af06660b75b728a1a9
EBUILD buildbot-wsgi-dashboards-0.9.11.ebuild 1149 SHA256 aef5bb31637e237292329c610e7c4ee390adb8ed92a6ac8cf94348dd8723aaa2 SHA512 c79a8319c6d3496cf1b9e7e2b5314e8fa58ef8322e0b4e6d1b3e45f90076063c5a0812a86ce76a0fa97345605474dad51c60670b0e9c0d5110cbf4764840bf1e WHIRLPOOL 581a6d750af5ad57595c0330bbacfe5fa533761c22f6b1d5c8921f750f3ac68272c785e82a5f27a2dc43ad0916097daa534fc7e373a0ea7e799ee1aa19769f84
+EBUILD buildbot-wsgi-dashboards-0.9.12.ebuild 1149 SHA256 aef5bb31637e237292329c610e7c4ee390adb8ed92a6ac8cf94348dd8723aaa2 SHA512 c79a8319c6d3496cf1b9e7e2b5314e8fa58ef8322e0b4e6d1b3e45f90076063c5a0812a86ce76a0fa97345605474dad51c60670b0e9c0d5110cbf4764840bf1e WHIRLPOOL 581a6d750af5ad57595c0330bbacfe5fa533761c22f6b1d5c8921f750f3ac68272c785e82a5f27a2dc43ad0916097daa534fc7e373a0ea7e799ee1aa19769f84
MISC metadata.xml 790 SHA256 d00575352bc63fe4e7b77eb26e120689fd6a8cde90dbb61d5e2b0d68b0fda7be SHA512 15928eff7b660deca2fa007e8924a8c878f4694880a3e0d2092a63b9fc745fbe91f77ae4af65d1ecd1f593519dcfd6b4f495cbef16704680826b00bfc5b4cf4b WHIRLPOOL d6013034f5d0da76fb9ea889a5bd4f77ba67fdf03433f850772a7349969785d17ea1f0592750a428e30eb60ec3f11d5076b9b3832b451b53cc3a463dff1bfbb7
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-0.9.12.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-0.9.12.ebuild
new file mode 100644
index 000000000000..cf9810a5d1c1
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-0.9.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_5 )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-wsgi-dashboards"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}