summaryrefslogtreecommitdiff
path: root/dev-util/buildbot-wsgi-dashboards
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-util/buildbot-wsgi-dashboards
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-util/buildbot-wsgi-dashboards')
-rw-r--r--dev-util/buildbot-wsgi-dashboards/Manifest4
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.4.0.ebuild1
-rw-r--r--dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.5.0.ebuild28
3 files changed, 32 insertions, 1 deletions
diff --git a/dev-util/buildbot-wsgi-dashboards/Manifest b/dev-util/buildbot-wsgi-dashboards/Manifest
index 123ad2cc37dd..50aa91f84774 100644
--- a/dev-util/buildbot-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-wsgi-dashboards/Manifest
@@ -1,3 +1,5 @@
DIST buildbot-wsgi-dashboards-3.4.0.tar.gz 5583 BLAKE2B 0eed4a375330d58bd6caf95f8cdc2ebfaebc9c123450461d4e0f938745bb1b6afe0e9786bd886c6e6cb6a522da2b645bf1ad3237b2049f86bc1bca83829b15a1 SHA512 56411bb34a1f40d02a814e8d33dcd3c6de65627728c3bb9cad776c43c48707e648ccdbb4a58cbfb8ed080c219fc37252304c88ab363eb6deb6057b2debde1071
-EBUILD buildbot-wsgi-dashboards-3.4.0.ebuild 712 BLAKE2B f8e978b24080c03603accfd185a50026408274302b20ed38560bbc75c662aedfcae0a2b0680c927505b0ba5f5e9df215edcb1d536184af496bac34e0c1b6c38f SHA512 22dfbd299cf708d8527fa1caca6d15a027be6075cea1de565764d04572c7d7833edbbe9a7989f2af302a3deeac21f57b8a71f2388f60035e03e6281f71833e94
+DIST buildbot-wsgi-dashboards-3.5.0.tar.gz 5585 BLAKE2B 94c365d4140de539a0ea85b78e24acd5d789fe022eb5ff2474ebc07554d139d964c9625b684b312b2134c3fd4bf3a6628178ac72d52283bb6fcfd7b7820d51f1 SHA512 d233273c05f9c2f6d81091dd620469dd19377848d5958c26cc746b6340ea9451c49aff8f8a36986741b3775fcc60065e0fbc402183f60f43d4afce238b907fd0
+EBUILD buildbot-wsgi-dashboards-3.4.0.ebuild 744 BLAKE2B 3fd09fab4929e3bb190370108cc583fe2df25514c79d60b16a332f516782a32cad2ea1c0a0e52a8e7b3c1e9e1327b536d18269cdb21d61c7f4bd16edf9303958 SHA512 b3a3e3e987888f539f2374e698042ad4f2a1ebb9c77f4921c75255964b469a393859220b56eae830830f5575ce58fcb2b5ae9dd627b81a5e3a203799ada10346
+EBUILD buildbot-wsgi-dashboards-3.5.0.ebuild 744 BLAKE2B 3fd09fab4929e3bb190370108cc583fe2df25514c79d60b16a332f516782a32cad2ea1c0a0e52a8e7b3c1e9e1327b536d18269cdb21d61c7f4bd16edf9303958 SHA512 b3a3e3e987888f539f2374e698042ad4f2a1ebb9c77f4921c75255964b469a393859220b56eae830830f5575ce58fcb2b5ae9dd627b81a5e3a203799ada10346
MISC metadata.xml 680 BLAKE2B b3fea763f6f493b0fb8be5e0408f80b295a5d205c5d01443e3a47965a5c982dbcc8e1f806978b0d8939e31ffeaa425590f9be8d5b563f0c064d700b1f33343be SHA512 01aeda23d466d40dc4c2bf7668595795fb6f743930c168549f259fd2a6e0f3491044079ef039096d030dec48ebb2bf3977bb5084264381675984cf43e063e083
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.4.0.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.4.0.ebuild
index 0bd0ca928a28..b67bfb3e65bf 100644
--- a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.4.0.ebuild
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.4.0.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_REQ_USE="sqlite"
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
diff --git a/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.5.0.ebuild b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.5.0.ebuild
new file mode 100644
index 000000000000..b67bfb3e65bf
--- /dev/null
+++ b/dev-util/buildbot-wsgi-dashboards/buildbot-wsgi-dashboards-3.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-wsgi-dashboards/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"