summaryrefslogtreecommitdiff
path: root/dev-util/build/build-0.3.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/build/build-0.3.10.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/build/build-0.3.10.ebuild')
-rw-r--r--dev-util/build/build-0.3.10.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/build/build-0.3.10.ebuild b/dev-util/build/build-0.3.10.ebuild
new file mode 100644
index 000000000000..d5ebc1b8dfc7
--- /dev/null
+++ b/dev-util/build/build-0.3.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator
+
+DESCRIPTION="A massively-parallel software build system implemented on top of GNU make"
+HOMEPAGE="https://www.codesynthesis.com/projects/build/"
+SLOT="0"
+SRC_URI="https://www.codesynthesis.com/download/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="!dev-util/build:0.3"
+
+src_install() {
+ emake install_prefix="${ED%/}/usr" install
+
+ HTML_DOCS=( documentation/*.{css,xhtml} )
+ einstalldocs
+ dodoc documentation/[[:upper:]]*
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}