summaryrefslogtreecommitdiff
path: root/dev-util/breakpad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-util/breakpad
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-util/breakpad')
-rw-r--r--dev-util/breakpad/Manifest5
-rw-r--r--dev-util/breakpad/breakpad-2022.06.04.ebuild58
-rw-r--r--dev-util/breakpad/files/breakpad-2022.06.04-gentoo.patch119
-rw-r--r--dev-util/breakpad/files/breakpad-2022.06.04-test.patch49
-rw-r--r--dev-util/breakpad/metadata.xml11
5 files changed, 242 insertions, 0 deletions
diff --git a/dev-util/breakpad/Manifest b/dev-util/breakpad/Manifest
new file mode 100644
index 000000000000..45434cdefeb7
--- /dev/null
+++ b/dev-util/breakpad/Manifest
@@ -0,0 +1,5 @@
+AUX breakpad-2022.06.04-gentoo.patch 3418 BLAKE2B cbcaabb31e17e45f7b2ed82a6bf6d0f0a587c205c4650d4ac813e8d44e7ac8b5cea7ea50836f40bd8175b96f8670522e09bc77826ab3af9bca45e98c32c529ff SHA512 424bbfd473acd5626abced365323282f95ccd95cd6bedaa30ffbb9d363ae42300dbe264e1d38d31ec8535b3730d42047a3a1b8f38ec845db1bb729be52375af1
+AUX breakpad-2022.06.04-test.patch 1949 BLAKE2B a5664ed800a6f51d980b82aced74c3bdcbd1608f19ebe2afc92ffa63bfc35ddb7fc0c2ba9b34112a46024553d0727123a0ee781e18c65170fc4792b77528f77a SHA512 9c83edad654678e098c702296bd6b0c308e516cab0a66a6b53ccffb9a8f7b7e6541cfc061cfa648d8538169d7297506a7da2369b6bcb1352f80eca0f09615e73
+DIST breakpad-2022.06.04.tar.gz 5365322 BLAKE2B eec33092a9a75161d16554af22276195945f3e1c7ce9590f89010a4d11484fe4327849c1717e159a9e019ca44d437b601b7080c68bba8c95111b97d6662dfc3f SHA512 150e5e955dc9de55d5cb4c726ae6f1a2e79e9f7bb283bae2ba835b684e7fd7532a7070e9ba982b66b68c936592bc48550a22ed8ac40e829b11aa80530f338749
+EBUILD breakpad-2022.06.04.ebuild 1086 BLAKE2B fb6a682152fbac44f5ca10c760e003461442fcb608064ebb9b00276272dc00d9a00719ee419cda33e1db4d2520591f2d524c14774153bee8031d010a6cc314ee SHA512 87de98b52d9c8e90cd50b0ee31e7f810a7ffd409e190a578c9ac6f000d43d2c478c05047abeb678f412867f748d87d869a761ed8ea1ea52db4886718d3afba0d
+MISC metadata.xml 328 BLAKE2B 1fb236117a2b1729f37d92c4cfd6a3ef2675e901467e0631a2be86d6f61c9e9103da96c730009aa3efb3e8846d2e9e77940ac925ea2700b87bee2ba7d148a2b8 SHA512 1f3b69819c461d2a3479490e963940db29211128b0f05faf60489f817fd69eabc79369e11d3f23299090e5bdb14399e72f54ee724e8f6b8a4b189859854cf951
diff --git a/dev-util/breakpad/breakpad-2022.06.04.ebuild b/dev-util/breakpad/breakpad-2022.06.04.ebuild
new file mode 100644
index 000000000000..d68490afa287
--- /dev/null
+++ b/dev-util/breakpad/breakpad-2022.06.04.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+CommitId=41a11409d6ba04e308adc66f5a33115e2d7c9174
+DESCRIPTION="implement a crash-reporting system."
+HOMEPAGE="https://chromium.googlesource.com/breakpad/breakpad/"
+SRC_URI="https://github.com/google/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD BSD-4"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ net-misc/curl
+"
+DEPEND="${RDEPEND}
+ dev-libs/linux-syscall-support
+ dev-embedded/libdisasm
+"
+BDEPEND="test? ( dev-cpp/gtest )"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's|"third_party/lss\(.*\)"|<lss\1>|' \
+ $(find src -name '*.cc' -o -name '*.h') \
+ || die
+ sed -i \
+ -e '/includelss/d' \
+ -e '/third_party\/curl/d' \
+ Makefile.am \
+ || die
+ sed -i \
+ -e "/AC_INIT/s:0.1:${PVR}:" \
+ configure.ac \
+ || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-system-test-libs \
+ || die
+}
diff --git a/dev-util/breakpad/files/breakpad-2022.06.04-gentoo.patch b/dev-util/breakpad/files/breakpad-2022.06.04-gentoo.patch
new file mode 100644
index 000000000000..e39190bfa5b9
--- /dev/null
+++ b/dev-util/breakpad/files/breakpad-2022.06.04-gentoo.patch
@@ -0,0 +1,119 @@
+--- a/src/common/linux/libcurl_wrapper.h 2022-06-07 21:55:00.387396660 +0200
++++ b/src/common/linux/libcurl_wrapper.h 2022-06-07 21:55:18.450145751 +0200
+@@ -37,7 +37,7 @@
+ #include <map>
+
+ #include "common/using_std_string.h"
+-#include "third_party/curl/curl.h"
++#include <curl/curl.h>
+
+ namespace google_breakpad {
+ class LibcurlWrapper {
+--- a/src/common/linux/http_upload.cc 2022-06-07 21:53:55.505298529 +0200
++++ b/src/common/linux/http_upload.cc 2022-06-07 21:54:17.944986506 +0200
+@@ -31,7 +31,7 @@
+
+ #include <assert.h>
+ #include <dlfcn.h>
+-#include "third_party/curl/curl.h"
++#include <curl/curl.h>
+
+ namespace {
+
+--- a/src/processor/disassembler_x86.h 2022-06-08 08:41:45.569686249 +0200
++++ b/src/processor/disassembler_x86.h 2022-06-08 08:42:09.049377873 +0200
+@@ -42,7 +42,7 @@
+ #include "google_breakpad/common/breakpad_types.h"
+
+ namespace libdis {
+-#include "third_party/libdisasm/libdis.h"
++#include <libdis.h>
+ }
+
+ namespace google_breakpad {
+--- a/Makefile.am 2022-06-08 08:51:35.221948155 +0200
++++ b/Makefile.am 2022-06-08 08:53:21.679551745 +0200
+@@ -142,7 +142,6 @@
+ if !DISABLE_PROCESSOR
+ lib_LIBRARIES += src/libbreakpad.a
+ pkgconfig_DATA += breakpad.pc
+-noinst_LIBRARIES += src/third_party/libdisasm/libdisasm.a
+ endif
+
+ if LINUX_HOST
+@@ -885,7 +885,7 @@
+ src/processor/stackwalker_x86.o \
+ src/processor/symbolic_constants_win.o \
+ src/processor/tokenize.o \
+- src/third_party/libdisasm/libdisasm.a \
++ -ldisasm \
+ $(TEST_LIBS) \
+ $(PTHREAD_CFLAGS) $(PTHREAD_LIBS)
+
+@@ -895,7 +895,7 @@
+ $(AM_CPPFLAGS) $(TEST_CFLAGS)
+ src_processor_disassembler_x86_unittest_LDADD = \
+ src/processor/disassembler_x86.o \
+- src/third_party/libdisasm/libdisasm.a \
++ -ldisasm \
+ $(TEST_LIBS) \
+ $(PTHREAD_CFLAGS) $(PTHREAD_LIBS)
+
+@@ -997,7 +997,7 @@
+ src/processor/stackwalker_x86.o \
+ src/processor/symbolic_constants_win.o \
+ src/processor/tokenize.o \
+- src/third_party/libdisasm/libdisasm.a \
++ -ldisasm \
+ $(TEST_LIBS) \
+ $(PTHREAD_CFLAGS) $(PTHREAD_LIBS)
+
+@@ -1027,7 +1027,7 @@
+ src_processor_proc_maps_linux_unittest_LDADD = \
+ src/processor/logging.o \
+ src/processor/pathname_stripper.o \
+- src/third_party/libdisasm/libdisasm.a \
++ -ldisasm \
+ $(TEST_LIBS) \
+ $(PTHREAD_CFLAGS) $(PTHREAD_LIBS)
+
+@@ -1307,7 +1307,7 @@
+ src/processor/stackwalker_sparc.o \
+ src/processor/stackwalker_x86.o \
+ src/processor/tokenize.o \
+- src/third_party/libdisasm/libdisasm.a
++ -ldisasm
+
+ src_processor_minidump_stackwalk_SOURCES = \
+ src/processor/minidump_stackwalk.cc
+@@ -1347,7 +1347,7 @@
+ src/processor/stackwalker_x86.o \
+ src/processor/symbolic_constants_win.o \
+ src/processor/tokenize.o \
+- src/third_party/libdisasm/libdisasm.a
++ -ldisasm
+
+ endif !DISABLE_PROCESSOR
+
+--- a/src/processor/exploitability_win.cc 2022-06-08 08:59:44.437471336 +0200
++++ b/src/processor/exploitability_win.cc 2022-06-08 09:00:04.061210421 +0200
+@@ -44,7 +44,7 @@
+ #include "processor/disassembler_x86.h"
+ #include "processor/logging.h"
+
+-#include "third_party/libdisasm/libdis.h"
++#include <libdis.h>
+
+ namespace google_breakpad {
+
+--- a/src/processor/disassembler_x86_unittest.cc 2022-06-08 10:30:23.370615114 +0200
++++ b/src/processor/disassembler_x86_unittest.cc 2022-06-08 10:30:44.003341412 +0200
+@@ -31,7 +31,7 @@
+
+ #include "breakpad_googletest_includes.h"
+ #include "processor/disassembler_x86.h"
+-#include "third_party/libdisasm/libdis.h"
++#include <libdis.h>
+
+ namespace {
+
diff --git a/dev-util/breakpad/files/breakpad-2022.06.04-test.patch b/dev-util/breakpad/files/breakpad-2022.06.04-test.patch
new file mode 100644
index 000000000000..7bf1d78290ab
--- /dev/null
+++ b/dev-util/breakpad/files/breakpad-2022.06.04-test.patch
@@ -0,0 +1,49 @@
+--- a/src/common/dwarf_cu_to_module_unittest.cc 2022-06-06 21:31:46.537946012 +0200
++++ b/src/common/dwarf_cu_to_module_unittest.cc 2022-06-06 21:33:27.299716909 +0200
+@@ -780,7 +780,7 @@
+ 0x2805c4531be6ca0eULL, 0x686b52155a8d4d2cULL);
+ }
+
+-TEST_F(SimpleCU, UnknownAbstractOrigin) {
++TEST_F(SimpleCU, DISABLED_UnknownAbstractOrigin) {
+ EXPECT_CALL(reporter_, UnknownAbstractOrigin(_, 1ULL)).WillOnce(Return());
+ EXPECT_CALL(reporter_, UnnamedFunction(0x11c70f94c6e87ccdLL))
+ .WillOnce(Return());
+@@ -798,7 +798,7 @@
+ 0x1758a0f941b71efbULL, 0x1cf154f1f545e146ULL);
+ }
+
+-TEST_F(SimpleCU, UnnamedFunction) {
++TEST_F(SimpleCU, DISABLED_UnnamedFunction) {
+ EXPECT_CALL(reporter_, UnnamedFunction(0xe34797c7e68590a8LL))
+ .WillOnce(Return());
+ PushLine(0x72b80e41a0ac1d40ULL, 0x537174f231ee181cULL, "line-file", 14044850);
+@@ -1573,7 +1573,7 @@
+ EXPECT_STREQ("class_A::member_func_B", functions[0]->name.str().c_str());
+ }
+
+-TEST_F(Specifications, UnhandledInterCU) {
++TEST_F(Specifications, DISABLED_UnhandledInterCU) {
+ Module m("module-name", "module-os", "module-arch", "module-id");
+ DwarfCUToModule::FileContext fc("dwarf-filename", &m, false);
+ EXPECT_CALL(reporter_, UncoveredFunction(_)).WillOnce(Return());
+@@ -1630,7 +1630,7 @@
+ }
+ }
+
+-TEST_F(Specifications, BadOffset) {
++TEST_F(Specifications, DISABLED_BadOffset) {
+ PushLine(0xa0277efd7ce83771ULL, 0x149554a184c730c1ULL, "line-file", 56636272);
+ EXPECT_CALL(reporter_, UnknownSpecification(_, 0x2be953efa6f9a996ULL))
+ .WillOnce(Return());
+--- a/src/common/module_unittest.cc 2022-06-06 21:33:46.167486242 +0200
++++ b/src/common/module_unittest.cc 2022-06-06 21:34:02.480286684 +0200
+@@ -427,7 +427,7 @@
+ contents.c_str());
+ }
+
+-TEST(Construct, FunctionsWithSameAddress) {
++TEST(Construct, DISABLED_FunctionsWithSameAddress) {
+ stringstream s;
+ Module m(MODULE_NAME, MODULE_OS, MODULE_ARCH, MODULE_ID);
+
diff --git a/dev-util/breakpad/metadata.xml b/dev-util/breakpad/metadata.xml
new file mode 100644
index 000000000000..99c21f0c89d6
--- /dev/null
+++ b/dev-util/breakpad/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/breakpad</remote-id>
+ </upstream>
+</pkgmetadata>