summaryrefslogtreecommitdiff
path: root/dev-util/bpftool/bpftool-5.19.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-18 05:56:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-18 05:56:19 +0000
commit3b34ca9eec2676e6fe530f34e463f52308a11441 (patch)
tree851348b7aaa208dd7852f8ddeb950b6395b2e1bc /dev-util/bpftool/bpftool-5.19.12.ebuild
parentb8f9cc8d0880d028eb7536742f0042580b55a72e (diff)
gentoo auto-resync : 18:01:2023 - 05:56:19
Diffstat (limited to 'dev-util/bpftool/bpftool-5.19.12.ebuild')
-rw-r--r--dev-util/bpftool/bpftool-5.19.12.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-util/bpftool/bpftool-5.19.12.ebuild b/dev-util/bpftool/bpftool-5.19.12.ebuild
index 71df5aaddcfa..fa8315db60c6 100644
--- a/dev-util/bpftool/bpftool-5.19.12.ebuild
+++ b/dev-util/bpftool/bpftool-5.19.12.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..10} )
-inherit estack linux-info optfeature python-any-r1 toolchain-funcs
+inherit estack linux-info optfeature python-any-r1 bash-completion-r1 toolchain-funcs
MY_PV="${PV/_/-}"
MY_PV="${MY_PV/-pre/-git}"
@@ -107,6 +107,7 @@ bpftool_make() {
HOSTCC="$(tc-getBUILD_CC)" HOSTLD="$(tc-getBUILD_LD)" \
EXTRA_CFLAGS="${CFLAGS}" ARCH="${arch}" BPFTOOL_VERSION="${MY_PV}" \
prefix="${EPREFIX}"/usr \
+ bash_compdir="$(get_bashcompdir)" \
feature-libcap="$(usex caps 1 0)" \
"$@"
}