summaryrefslogtreecommitdiff
path: root/dev-util/boost-build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-util/boost-build
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-util/boost-build')
-rw-r--r--dev-util/boost-build/Manifest2
-rw-r--r--dev-util/boost-build/boost-build-1.79.0.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/boost-build/Manifest b/dev-util/boost-build/Manifest
index a59fbe0b143a..605b4c725a5c 100644
--- a/dev-util/boost-build/Manifest
+++ b/dev-util/boost-build/Manifest
@@ -10,6 +10,8 @@ AUX boost-build-1.78.0-no-implicit-march-flags.patch 17236 BLAKE2B c8c068f48de2d
AUX site-config.jam 688 BLAKE2B e43a7ad1a94d113a7f890e8b634770f5c60556101d428d83f655bbbe72c46b587485886a9941d05a2ae4319fc325f1e0ecfb9b660158b81c5e9fd02e0b1c0530 SHA512 b65bf1be3133f9f66d3139b00f195a288591bb20a13ba35041507c2c33d7d2da6047c3b02dc27bc4eb21798b91e1262a60e294b7fd4af90808b9de0f5af517df
DIST boost_1_77_0.tar.bz2 110361537 BLAKE2B 106aeb09ec7705b595f2ca966a76c53c649eac6fac50d88c156862e0991c33c89a2f3a09edcbcb453fa44bf71cdde030b35d0a0889ad97b65f3a868cb877a532 SHA512 39b45c9b60bc5a2a4c669a4463d1272c1e093376b2fb374d7f20a84ea10a3e23bb04b335a735a83a04575731f874d9bff77e89acd947524b3fbbae1b26ae1f2f
DIST boost_1_78_0.tar.bz2 110675550 BLAKE2B ed7da98862ec1e0a28472544400e6f44ffadbc967eed969ce6cb62b1c4f0b7a4b98a395269eb374b57326eff9cdb1dd6e47df9d1a9730aff7c926cc44388fb2d SHA512 9c34a387a203b99aa773eb0c59f5abac7a99ba10e4623653e793c1d5b29b99b88e0e4e0d4e2e4ca5d497c42f2e46e23bab66417722433a457dc818d7670bcbbf
+DIST boost_1_79_0.tar.bz2 113456811 BLAKE2B 61f47ca022e60745868e6bdd3b5c75603dd68d878e126dcbb73de5b40fc03c0eec8eede3ec304ece58050435ef2fc1ed7eb763773c20673f85e32bbf4d5f978a SHA512 70909e0561c213d10a1fdd692f9ae7b293d3cdc63e925bdc207da9e9bba6e86474341100e7ee5de6d94f9561196b1a3a1597055a7b7382babf8931131170a312
EBUILD boost-build-1.77.0.ebuild 2114 BLAKE2B 28bfad497b939cb453f6010fbeea0e46fd7ffff6009ab65f7404b842399e2941065e33477d293d5983fa4269d90b2d8cec017537d010d11c40e8d9c94e3d2f30 SHA512 677e523abbb7f97475a91b87bb592c6fbf8674d6baec28bfc24bbec32636476430266b5cab2f1c6b357cd84ce7fc99294896ea9431ac2e0987270a8012470384
EBUILD boost-build-1.78.0-r1.ebuild 2166 BLAKE2B e65979c0a57bc8d4c30514f51be2051ed73b33221d69fccc429dacf699c8ce9fb2e65c39cd6c04a511ab1c33ccbcc73bdeac9e3de8a1de3a8994678e3e6fa561 SHA512 7f3c708126c863f3cc052f16442bc360dcdff51be044b1f820820a5d70a7404e4e104d75556cd7e487e31f6c16cd095ffa05b495b60cdc04cd0332d3183c3fbe
+EBUILD boost-build-1.79.0.ebuild 2122 BLAKE2B 6336069e4e4439a46bc2790ae7377189763ff26628b06b54d64671241c4ed1be392691e62978b024b004cc9f6087e3b6ffb31e9b570990791b10dac87846c61d SHA512 124e4ebf118b7967dc72220c13d4665ef203533ed7a9c8e0f0073e7a91de5bd3d2e2a98e11b45d0c6f6895b4154d892867aead3eb46773f86dda250e1a019012
MISC metadata.xml 320 BLAKE2B b8916adb7b84ead3feef70414578019e07de58086e6954cf2a26a77368a99bc75bf99ca18f111a67531d318863fab700083ebcd7612e7d40ece89086d9d4974c SHA512 7c2c8fa591a6c3d05b5d4808077b890d5757bbb4c12a9fe7ed7b4ebc738244266196baba07da434ac3609c0d00aed4ef9c2346524f141e679b94376f804c508b
diff --git a/dev-util/boost-build/boost-build-1.79.0.ebuild b/dev-util/boost-build/boost-build-1.79.0.ebuild
new file mode 100644
index 000000000000..5efc205f8f68
--- /dev/null
+++ b/dev-util/boost-build/boost-build-1.79.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+MY_PV="$(ver_rs 1- _)"
+
+DESCRIPTION="A system for large project software construction, simple to use and powerful"
+HOMEPAGE="https://www.boost.org/build/"
+SRC_URI="https://boostorg.jfrog.io/artifactory/main/release/${PV}/source/boost_${MY_PV}.tar.bz2"
+S="${WORKDIR}/boost_${MY_PV}/tools/build/src"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.71.0-disable_python_rpath.patch
+ "${FILESDIR}"/${PN}-1.78.0-darwin-gentoo-toolchain.patch
+ "${FILESDIR}"/${PN}-1.73.0-add-none-feature-options.patch
+ "${FILESDIR}"/${PN}-1.76.0-respect-user-flags.patch
+ "${FILESDIR}"/${PN}-1.78.0-no-implicit-march-flags.patch
+)
+
+src_unpack() {
+ tar xojf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
+}
+
+src_prepare() {
+ default
+
+ pushd .. >/dev/null || die
+ eapply "${FILESDIR}"/${PN}-1.71.0-fix-test.patch
+ popd >/dev/null || die
+}
+
+src_configure() {
+ # need to enable LFS explicitly for 64-bit offsets on 32-bit hosts (#761100)
+ append-lfs-flags
+}
+
+src_compile() {
+ cd engine || die
+ ${CONFIG_SHELL:-${BASH}} ./build.sh cxx --cxx="$(tc-getCXX)" --cxxflags="${CXXFLAGS}" -d+2 --without-python || die "building bjam failed"
+}
+
+src_test() {
+ # Forget tests, bjam is a lost cause
+ :
+}
+
+src_install() {
+ dobin engine/{bjam,b2}
+
+ insinto /usr/share/boost-build/src
+ doins -r "${FILESDIR}/site-config.jam" \
+ ../boost-build.jam bootstrap.jam build-system.jam ../example/user-config.jam *.py \
+ build kernel options tools util
+
+ find "${ED}"/usr/share/boost-build/src -iname '*.py' -delete || die
+
+ dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
+
+ if use examples; then
+ docinto examples
+ dodoc -r ../example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}