summaryrefslogtreecommitdiff
path: root/dev-util/blueprint-compiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-24 15:02:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-24 15:02:35 +0100
commit59c803bef0bf9b4f167918783e386c3ddb746751 (patch)
treee57c71b0e5edaa64821fa7862dd9f8ba9c1030f0 /dev-util/blueprint-compiler
parentbd2c7873be3178619accade4259ba907b6baca46 (diff)
gentoo auto-resync : 24:05:2023 - 15:02:35
Diffstat (limited to 'dev-util/blueprint-compiler')
-rw-r--r--dev-util/blueprint-compiler/Manifest2
-rw-r--r--dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-util/blueprint-compiler/Manifest b/dev-util/blueprint-compiler/Manifest
index 9e8997f68c31..d596d314830d 100644
--- a/dev-util/blueprint-compiler/Manifest
+++ b/dev-util/blueprint-compiler/Manifest
@@ -1,3 +1,5 @@
DIST blueprint-compiler-v0.6.0.tar.bz2 56896 BLAKE2B 318ffa52b2fbf3b07058e5b4d2f9bb0ef1f6614586b79968889921964b454e5c26d44e58a18185263797f7569135662d14471bafd8e501d7c6386e88972193d0 SHA512 458016f4eabef15026cb3ee675111984b19af8a9139bc412dfb48dfef56b0d0ff028316001d0ce04a90b50d6785c92d799f17ed42ca53fc7582345729ae02207
+DIST blueprint-compiler-v0.8.1.tar.bz2 80762 BLAKE2B 9acd4a8e2e5d993a94bcf2c80530553a8f6c8977ebe94274e6a208935f6ddaf21dd1946ab80e08b4e61e16a8ff892301d9f9cf82f7af6e8d53c3b2fce3996592 SHA512 94a4651a54d69df1bcfa3e7219cefb2eca187808d0c2a580c135583fa0e2848a011a72204a567c48fce20a246d41667f7cbf147a34980b34c0914b4fc5868efb
EBUILD blueprint-compiler-0.6.0-r2.ebuild 1351 BLAKE2B 2ba0fe5157a9ec7e3951fc9bf6874db21a9f7b7bbbfc982dc12e0c71181dc637e758bc194dd7cab86802bc972a6ba025b5d0eebc8c98471c1c92ef1da510cc60 SHA512 9099bc9f5beb3aa6369e337b76a42c0b3091dddac9a795a10228b9d2a28440fd8670f6541197b68e20f9efaf41d2692b81de268e506fa558646b88b005e77344
+EBUILD blueprint-compiler-0.8.1.ebuild 1439 BLAKE2B adf12f921e9258a4e8f8e1717aa5c7902b337aeda867df62076b44926d447e7ea49314a9ccf747d4599216804b5d8de86fbbe3314d1952e2fd10fad7e49dc596 SHA512 98bf8ccb612865b8ff6e9dd7752a3853057948984d4d88d5163f70c3697ea04449af6bfc35809a743e3fc95fc8714773b33ea103afaaa8c10108aa7748bb6c47
MISC metadata.xml 906 BLAKE2B 8426e8a64268f0c3310028be81cc727a63ddd67df842d59eae80c55b12c41f446107cc61ed11c115da8b4cc9a67bb16b1d5c9dc09e541f41901eac29611f3e9d SHA512 3af397704e2717cbba16c890af04066cd67f40c1cc477429d3c53b713c079101036a17e788c0f5e316799cbfc8329356686ad129bfbed409002d96df3159d480
diff --git a/dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild b/dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild
new file mode 100644
index 000000000000..d93144b69f51
--- /dev/null
+++ b/dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit meson python-single-r1 virtualx
+
+DESCRIPTION="Compiler for Blueprint, a markup language for GTK user interfaces"
+HOMEPAGE="https://jwestman.pages.gitlab.gnome.org/blueprint-compiler/
+ https://gitlab.gnome.org/jwestman/blueprint-compiler/"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/jwestman/${PN}.git"
+else
+ SRC_URI="https://gitlab.gnome.org/jwestman/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}"/${PN}-v${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/furo[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+ )
+ test? (
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ )
+"
+
+DOCS=( CONTRIBUTING.md MAINTENANCE.md NEWS.md README.md )
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_use doc docs)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+
+ use doc && build_sphinx docs
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize
+}