summaryrefslogtreecommitdiff
path: root/dev-util/blueprint-compiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-14 00:16:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-14 00:16:43 +0000
commit55b20c97078ded20d0e7c6b3ef33d673c861d8b4 (patch)
tree92579cc158fd711b487e332cf87f87f3cf489d69 /dev-util/blueprint-compiler
parent8c9b482f4679667d7b439749d9a9c65d559d11b8 (diff)
gentoo auto-resync : 14:03:2023 - 00:16:42
Diffstat (limited to 'dev-util/blueprint-compiler')
-rw-r--r--dev-util/blueprint-compiler/Manifest3
-rw-r--r--dev-util/blueprint-compiler/blueprint-compiler-0.6.0.ebuild64
-rw-r--r--dev-util/blueprint-compiler/metadata.xml21
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-util/blueprint-compiler/Manifest b/dev-util/blueprint-compiler/Manifest
new file mode 100644
index 000000000000..489fe5c7c8d7
--- /dev/null
+++ b/dev-util/blueprint-compiler/Manifest
@@ -0,0 +1,3 @@
+DIST blueprint-compiler-v0.6.0.tar.bz2 56896 BLAKE2B 318ffa52b2fbf3b07058e5b4d2f9bb0ef1f6614586b79968889921964b454e5c26d44e58a18185263797f7569135662d14471bafd8e501d7c6386e88972193d0 SHA512 458016f4eabef15026cb3ee675111984b19af8a9139bc412dfb48dfef56b0d0ff028316001d0ce04a90b50d6785c92d799f17ed42ca53fc7582345729ae02207
+EBUILD blueprint-compiler-0.6.0.ebuild 1316 BLAKE2B cda7da45a84d7fce71fe5841b8310d350e129b6dc4fa09070e28bd2b601fe3b0f8e15b41202940a9304e8d767a2c1fed8b0c27335d552004a8c518a6f7a48331 SHA512 a81de37e626a0791e43a1594f393265e9b902d58470dd71e9076e46217a7b3a246e00f14b4c7da67feef5e018b23d874da06331fee41bdf197aac0abee21f63c
+MISC metadata.xml 906 BLAKE2B 8426e8a64268f0c3310028be81cc727a63ddd67df842d59eae80c55b12c41f446107cc61ed11c115da8b4cc9a67bb16b1d5c9dc09e541f41901eac29611f3e9d SHA512 3af397704e2717cbba16c890af04066cd67f40c1cc477429d3c53b713c079101036a17e788c0f5e316799cbfc8329356686ad129bfbed409002d96df3159d480
diff --git a/dev-util/blueprint-compiler/blueprint-compiler-0.6.0.ebuild b/dev-util/blueprint-compiler/blueprint-compiler-0.6.0.ebuild
new file mode 100644
index 000000000000..b54ac7882f03
--- /dev/null
+++ b/dev-util/blueprint-compiler/blueprint-compiler-0.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit meson python-single-r1
+
+DESCRIPTION="Compiler for Blueprint, a markup language for GTK user interfaces"
+HOMEPAGE="https://jwestman.pages.gitlab.gnome.org/blueprint-compiler/
+ https://gitlab.gnome.org/jwestman/blueprint-compiler/"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/jwestman/${PN}.git"
+else
+ SRC_URI="https://gitlab.gnome.org/jwestman/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ S="${WORKDIR}"/${PN}-v${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="
+ ${RDEPEND}
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/furo[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+ )
+ test? (
+ gui-libs/gtk:4[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+DOCS=( CONTRIBUTING.md MAINTENANCE.md NEWS.md README.md )
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_use doc docs)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+
+ use doc && build_sphinx docs
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
diff --git a/dev-util/blueprint-compiler/metadata.xml b/dev-util/blueprint-compiler/metadata.xml
new file mode 100644
index 000000000000..c28d6bd1544b
--- /dev/null
+++ b/dev-util/blueprint-compiler/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Blueprint helps you build user interfaces in GTK quickly and declaratively.
+ It has modern IDE features like code completion and hover documentation,
+ and the compiler points out mistakes early on so you can focus on making
+ your app look amazing.
+ </longdescription>
+ <upstream>
+ <changelog>https://gitlab.gnome.org/jwestman/blueprint-compiler/-/raw/main/NEWS.md</changelog>
+ <doc>https://jwestman.pages.gitlab.gnome.org/blueprint-compiler/</doc>
+ <bugs-to>https://github.com/jwestman/blueprint-compiler/issues</bugs-to>
+ <remote-id type="gnome-gitlab">jwestman/blueprint-compiler</remote-id>
+ </upstream>
+</pkgmetadata>