summaryrefslogtreecommitdiff
path: root/dev-util/blueprint-compiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
commit12795ed0561fe52503d6aa3a1c60888553a03bd2 (patch)
treebebc6554f117bd11f5e1c3503ed66966afcb5f3f /dev-util/blueprint-compiler
parent7e8f2c69a019131eaeb989242d022260ea5a84ff (diff)
gentoo auto-resync : 26:10:2023 - 20:41:49
Diffstat (limited to 'dev-util/blueprint-compiler')
-rw-r--r--dev-util/blueprint-compiler/Manifest2
-rw-r--r--dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild72
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-util/blueprint-compiler/Manifest b/dev-util/blueprint-compiler/Manifest
index 941d0da25298..85558e47729d 100644
--- a/dev-util/blueprint-compiler/Manifest
+++ b/dev-util/blueprint-compiler/Manifest
@@ -1,5 +1,3 @@
DIST blueprint-compiler-v0.10.0.tar.bz2 81856 BLAKE2B 8e63c27fc160244eb11776ea57c57b9c4b06aded76f3d59fc3190609f20a58985e3e800eebb5c69e681f8f8aba35f06f457f4dde241f78ff76d3e9348c4df46d SHA512 5d6a14a42aed64a82572a59730d454a920938d3b2c8aa1e61ab1d5fba47647ab5e3d6201c8ffe3e622b450ffcfb1eaf106951489897422c3e578d4d3695ae9ab
-DIST blueprint-compiler-v0.8.1.tar.bz2 80762 BLAKE2B 9acd4a8e2e5d993a94bcf2c80530553a8f6c8977ebe94274e6a208935f6ddaf21dd1946ab80e08b4e61e16a8ff892301d9f9cf82f7af6e8d53c3b2fce3996592 SHA512 94a4651a54d69df1bcfa3e7219cefb2eca187808d0c2a580c135583fa0e2848a011a72204a567c48fce20a246d41667f7cbf147a34980b34c0914b4fc5868efb
EBUILD blueprint-compiler-0.10.0.ebuild 1438 BLAKE2B 56cbcbe4622e0f2fc95ec8e7eade565114b8b492e8b551d9537cf667a1391e103fb978928beccf6e98cd67afb9ce45cbeedab53c81c165e84263b2d199d5a708 SHA512 3fcd96861116130252036a18d1522411d810ae2cf8b08bc169306a0c4bab358caee8d1e095495d2779959ded0b374a55e3a7599f4a44823104560f377b12bd2c
-EBUILD blueprint-compiler-0.8.1.ebuild 1438 BLAKE2B 56cbcbe4622e0f2fc95ec8e7eade565114b8b492e8b551d9537cf667a1391e103fb978928beccf6e98cd67afb9ce45cbeedab53c81c165e84263b2d199d5a708 SHA512 3fcd96861116130252036a18d1522411d810ae2cf8b08bc169306a0c4bab358caee8d1e095495d2779959ded0b374a55e3a7599f4a44823104560f377b12bd2c
MISC metadata.xml 906 BLAKE2B 8426e8a64268f0c3310028be81cc727a63ddd67df842d59eae80c55b12c41f446107cc61ed11c115da8b4cc9a67bb16b1d5c9dc09e541f41901eac29611f3e9d SHA512 3af397704e2717cbba16c890af04066cd67f40c1cc477429d3c53b713c079101036a17e788c0f5e316799cbfc8329356686ad129bfbed409002d96df3159d480
diff --git a/dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild b/dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild
deleted file mode 100644
index 4b1218894eed..000000000000
--- a/dev-util/blueprint-compiler/blueprint-compiler-0.8.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit meson python-single-r1 virtualx
-
-DESCRIPTION="Compiler for Blueprint, a markup language for GTK user interfaces"
-HOMEPAGE="https://jwestman.pages.gitlab.gnome.org/blueprint-compiler/
- https://gitlab.gnome.org/jwestman/blueprint-compiler/"
-
-if [[ ${PV} == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.gnome.org/jwestman/${PN}.git"
-else
- SRC_URI="https://gitlab.gnome.org/jwestman/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
- S="${WORKDIR}"/${PN}-v${PV}
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="LGPL-3+"
-SLOT="0"
-IUSE="doc test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
-"
-BDEPEND="
- ${RDEPEND}
- doc? (
- $(python_gen_cond_dep '
- dev-python/furo[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- ')
- )
- test? (
- gui-libs/gtk:4[introspection]
- gui-libs/libadwaita:1[introspection]
- )
-"
-
-DOCS=( CONTRIBUTING.md MAINTENANCE.md NEWS.md README.md )
-
-src_configure() {
- local -a emesonargs=(
- $(meson_use doc docs)
- )
- meson_src_configure
-}
-
-src_compile() {
- meson_src_compile
-
- use doc && build_sphinx docs
-}
-
-src_test() {
- virtx meson_src_test
-}
-
-src_install() {
- meson_src_install
- python_fix_shebang "${ED}"/usr/bin
- python_optimize
-}